]> code.ossystems Code Review - openembedded-core.git/commitdiff
pciutils: upgrade to 3.1.9
authorShane Wang <shane.wang@intel.com>
Sun, 22 Jan 2012 09:12:37 +0000 (17:12 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Jan 2012 11:23:58 +0000 (11:23 +0000)
Signed-off-by: Shane Wang <shane.wang@intel.com>
meta/recipes-bsp/pciutils/pciutils-3.1.9/configure.patch [moved from meta/recipes-bsp/pciutils/pciutils-3.1.7/configure.patch with 85% similarity]
meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch [moved from meta/recipes-bsp/pciutils/pciutils-3.1.7/guess-fix.patch with 100% similarity]
meta/recipes-bsp/pciutils/pciutils-3.1.9/lib-build-fix.patch [moved from meta/recipes-bsp/pciutils/pciutils-3.1.7/lib-build-fix.patch with 100% similarity]
meta/recipes-bsp/pciutils/pciutils-3.1.9/makefile.patch [moved from meta/recipes-bsp/pciutils/pciutils-3.1.7/makefile.patch with 100% similarity]
meta/recipes-bsp/pciutils/pciutils-3.1.9/pcimodules-pciutils.diff [moved from meta/recipes-bsp/pciutils/pciutils-3.1.7/pcimodules-pciutils.diff with 100% similarity]
meta/recipes-bsp/pciutils/pciutils_3.1.9.bb [moved from meta/recipes-bsp/pciutils/pciutils_3.1.7.bb with 91% similarity]

similarity index 85%
rename from meta/recipes-bsp/pciutils/pciutils-3.1.7/configure.patch
rename to meta/recipes-bsp/pciutils/pciutils-3.1.9/configure.patch
index ff6f20c68afb5c941fb8414a6df01b74674ff535..658e59772c86023e8f7219852c902d88b323a43f 100644 (file)
@@ -6,10 +6,40 @@ Upstream-Status: Inappropriate [embedded specific]
 ---
 
 7/30/2010 - rebased to 3.1.5 by Qing He <qing.he@intel.com>
+1/22/2012 - rebased to 3.1.9 by Shane Wang <shane.wang@intel.com>
 
-diff -uNr pciutils-3.1.5.orig/lib/configure pciutils-3.1.5/lib/configure
---- pciutils-3.1.5.orig/lib/configure  2010-07-30 13:51:58.000000000 +0800
-+++ pciutils-3.1.5/lib/configure       2010-07-30 13:53:25.000000000 +0800
+diff -r af2b10cc3c14 Makefile
+--- a/Makefile Sun Jan 22 18:36:34 2012 +0800
++++ b/Makefile Sun Jan 22 18:38:54 2012 +0800
+@@ -37,7 +37,6 @@
+ # Commands
+ INSTALL=install
+ DIRINSTALL=install -d
+-STRIP=-s
+ CC=$(CROSS_COMPILE)gcc
+ AR=$(CROSS_COMPILE)ar
+ RANLIB=$(CROSS_COMPILE)ranlib
+@@ -86,7 +85,7 @@
+ example.o: example.c $(PCIINC)
+ %: %.o
+-      $(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LDLIBS) -o $@
++      $(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LIB_LDLIBS) -o $@
+ %.8 %.7: %.man
+       M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#"
+@@ -101,7 +100,7 @@
+ install: all
+ # -c is ignored on Linux, but required on FreeBSD
+       $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7
+-      $(INSTALL) -c -m 755 $(STRIP) lspci setpci $(DESTDIR)$(SBINDIR)
++      $(INSTALL) -c -m 755 lspci setpci $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
+       $(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(IDSDIR)
+       $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
+diff -r af2b10cc3c14 lib/configure
+--- a/lib/configure    Sun Jan 22 18:36:34 2012 +0800
++++ b/lib/configure    Sun Jan 22 18:38:54 2012 +0800
 @@ -14,6 +14,10 @@
        fi
  }
@@ -36,8 +66,8 @@ diff -uNr pciutils-3.1.5.orig/lib/configure pciutils-3.1.5/lib/configure
                proc=`/usr/sbin/lsdev -C -c processor -S available -F name | head -1`
                cpu=`/usr/sbin/lsattr -F value -l $proc -a type | sed 's/_.*//'`
        else
--              cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`
-+              cpu=${4:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/'`}
+-              cpu=`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/'`
++              cpu=${4:-`uname -m | sed 's/^i.86$/i386/;s/^sun4u$/sparc64/;s/^i86pc$/i386/;s/^BePC$/i386/;s/^BeMac$/powerpc/;s/^BeBox$/powerpc/`}
        fi
        if [ "$sys" = "GNU/kFreeBSD" -o "$sys" = "DragonFly" ]
        then
@@ -72,32 +102,3 @@ diff -uNr pciutils-3.1.5.orig/lib/configure pciutils-3.1.5/lib/configure
  c=config.h
  m=config.mk
  echo >$c '#define PCI_CONFIG_H'
-diff -uNr pciutils-3.1.5.orig/Makefile pciutils-3.1.5/Makefile
---- pciutils-3.1.5.orig/Makefile       2010-07-30 13:51:58.000000000 +0800
-+++ pciutils-3.1.5/Makefile    2010-07-30 13:52:24.000000000 +0800
-@@ -37,7 +37,6 @@
- # Commands
- INSTALL=install
- DIRINSTALL=install -d
--STRIP=-s
- CC=$(CROSS_COMPILE)gcc
- AR=$(CROSS_COMPILE)ar
- RANLIB=$(CROSS_COMPILE)ranlib
-@@ -86,7 +85,7 @@
- example.o: example.c $(PCIINC)
- %: %.o
--      $(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LDLIBS) -o $@
-+      $(CC) $(LDFLAGS) $(TARGET_ARCH) $^ $(LIB_LDLIBS) -o $@
- %.8 %.7: %.man
-       M=`echo $(DATE) | sed 's/-01-/-January-/;s/-02-/-February-/;s/-03-/-March-/;s/-04-/-April-/;s/-05-/-May-/;s/-06-/-June-/;s/-07-/-July-/;s/-08-/-August-/;s/-09-/-September-/;s/-10-/-October-/;s/-11-/-November-/;s/-12-/-December-/;s/\(.*\)-\(.*\)-\(.*\)/\3 \2 \1/'` ; sed <$< >$@ "s/@TODAY@/$$M/;s/@VERSION@/pciutils-$(VERSION)/;s#@IDSDIR@#$(IDSDIR)#"
-@@ -101,7 +100,7 @@
- install: all
- # -c is ignored on Linux, but required on FreeBSD
-       $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7
--      $(INSTALL) -c -m 755 $(STRIP) lspci setpci $(DESTDIR)$(SBINDIR)
-+      $(INSTALL) -c -m 755 lspci setpci $(DESTDIR)$(SBINDIR)
-       $(INSTALL) -c -m 755 update-pciids $(DESTDIR)$(SBINDIR)
-       $(INSTALL) -c -m 644 $(PCI_IDS) $(DESTDIR)$(IDSDIR)
-       $(INSTALL) -c -m 644 lspci.8 setpci.8 update-pciids.8 $(DESTDIR)$(MANDIR)/man8
similarity index 91%
rename from meta/recipes-bsp/pciutils/pciutils_3.1.7.bb
rename to meta/recipes-bsp/pciutils/pciutils_3.1.9.bb
index b48aaf02c4837232ce4554421a85f9a6c21cc19f..51e74760454ba5b7cff0006a083d730f9c9b585b 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 DEPENDS = "zlib"
 RDEPENDS_${PN} = "${PN}-ids"
-PR = "r2"
+PR = "r0"
 
 SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
            file://configure.patch \
@@ -18,8 +18,8 @@ SRC_URI = "${KERNELORG_MIRROR}/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
            file://guess-fix.patch \
            file://makefile.patch"
 
-SRC_URI[md5sum] = "35222edb86b50a6641352c66fe829b2e"
-SRC_URI[sha256sum] = "d8fe23b6966c1abf29b3b38b08b0cf33f731cd6e6a89d9b8d2b8d5e982c3f544"
+SRC_URI[md5sum] = "79cc1d0bff8603d3a550fa63802cd1db"
+SRC_URI[sha256sum] = "e4ce5d56ae4a9611d51ba0cc2ea45806f9539a18aceb4aa70b8ded50f6923c4f"
 
 PARALLEL_MAKE = ""