]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: Fix issues from 4.0 upgrade
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 16 Oct 2018 09:51:18 +0000 (10:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 16 Oct 2018 19:25:37 +0000 (20:25 +0100)
4.0 adds systemd support but installs the unit files in the wrong location.
Fix this in do_install and inherit systemd to package them correctly.

Also fix ownership of files manually copied in to root:root to avoid QA warnings.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/systemtap/systemtap_git.bb

index 0b7833e901b9a624daf6204614dcdbd6e4acafca..3c45bfa93741334d18427ae645e65345b88058c1 100644 (file)
@@ -25,7 +25,7 @@ PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
 PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
 PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
 
-inherit autotools gettext pkgconfig distutils3-base
+inherit autotools gettext pkgconfig distutils3-base systemd
 
 do_configure_prepend () {
     # Improve reproducibility for c++ object files
@@ -39,6 +39,14 @@ do_install_append () {
       rm -rf ${D}${datadir}/${PN}
       rm ${D}${libexecdir}/${PN}/stap-env
    fi
+
+   # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
+   install -d `dirname ${D}${systemd_unitdir}`
+   mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
+   rmdir ${D}${prefix}/lib --ignore-fail-on-non-empty
+
+   # Ensure correct ownership for files copied in
+   chown root.root ${D}${sysconfdir}/stap-exporter/* -R
 }
 
 BBCLASSEXTEND = "nativesdk"