]> code.ossystems Code Review - openembedded-core.git/commitdiff
packagegroup-core-boot: conditionally rdepend on VIRTUAL-RUNTIME_initscripts
authorChen Qi <Qi.Chen@windriver.com>
Wed, 3 Sep 2014 07:09:15 +0000 (15:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Sep 2014 09:24:22 +0000 (10:24 +0100)
If we are building a systemd image with 'sysvinit' not in DISTRO_FEATURES,
the initscripts should not be installed into the image, as they are useless.
What's more, we as now support executing scripts under /etc/rcS.d, the
boot time will be increased by these scripts as the systemd will try to
translate them into temporary service files.

These init scritps are actually needed only when 'sysvinit' is in
DISTRO_FEATURES.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/packagegroups/packagegroup-core-boot.bb

index 886c33435c54902c56118e766ef407c3f36f9138..09f537372ee5a075261fa748311f82c1b9b4119d 100644 (file)
@@ -27,6 +27,7 @@ VIRTUAL-RUNTIME_keymaps ?= "keymaps"
 SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
                     modutils-initscripts \
                     init-ifupdown \
+                    ${VIRTUAL-RUNTIME_initscripts} \
                    "
 
 RDEPENDS_${PN} = "\
@@ -38,7 +39,6 @@ RDEPENDS_${PN} = "\
     netbase \
     ${VIRTUAL-RUNTIME_login_manager} \
     ${VIRTUAL-RUNTIME_init_manager} \
-    ${VIRTUAL-RUNTIME_initscripts} \
     ${VIRTUAL-RUNTIME_dev_manager} \
     ${VIRTUAL-RUNTIME_update-alternatives} \
     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"