]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: sync with OE (no package changes)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 11:52:46 +0000 (11:52 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 11:52:46 +0000 (11:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2959 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/bash/bash.inc [new file with mode: 0644]
meta/packages/bash/bash_3.2.bb

diff --git a/meta/packages/bash/bash.inc b/meta/packages/bash/bash.inc
new file mode 100644 (file)
index 0000000..80aedfa
--- /dev/null
@@ -0,0 +1,26 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+       gnu-configize
+       oe_runconf
+}
+
+pkg_postinst () {
+       touch ${sysconfdir}/shells
+       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}
index e3d6b0560c8787b3f0c03657880902c2468a2bc5..8e0293e0014ce519c032321ad5385420492c0558 100644 (file)
@@ -1,28 +1,5 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
+require bash.inc
+PR = "r1"
 
 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
            file://001-005.patch;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
-       gnu-configize
-       oe_runconf
-}
-
-pkg_postinst () {
-       grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
-       grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}