]> code.ossystems Code Review - openembedded-core.git/commitdiff
ovmf: Fix build with gcc7
authorKhem Raj <raj.khem@gmail.com>
Fri, 21 Apr 2017 20:55:22 +0000 (20:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 May 2017 11:21:33 +0000 (12:21 +0100)
backport a patch which fixing warnings with gcc7

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/ovmf/ovmf/0001-MdeModulePkg-UefiHiiLib-Fix-incorrect-comparison-exp.patch [new file with mode: 0644]
meta/recipes-core/ovmf/ovmf_git.bb

diff --git a/meta/recipes-core/ovmf/ovmf/0001-MdeModulePkg-UefiHiiLib-Fix-incorrect-comparison-exp.patch b/meta/recipes-core/ovmf/ovmf/0001-MdeModulePkg-UefiHiiLib-Fix-incorrect-comparison-exp.patch
new file mode 100644 (file)
index 0000000..0529a27
--- /dev/null
@@ -0,0 +1,45 @@
+From 73692710d50da1f421b0e6ddff784ca3135389b3 Mon Sep 17 00:00:00 2001
+From: Dandan Bi <dandan.bi@intel.com>
+Date: Sat, 1 Apr 2017 10:31:14 +0800
+Subject: [PATCH] MdeModulePkg/UefiHiiLib:Fix incorrect comparison expression
+
+Fix the incorrect comparison between pointer and constant zero character.
+
+https://bugzilla.tianocore.org/show_bug.cgi?id=416
+
+V2: The pointer StringPtr points to a string returned
+by ExtractConfig/ExportConfig, if it is NULL, function
+InternalHiiIfrValueAction will return FALSE. So in
+current usage model, the StringPtr can not be NULL before
+using it, so we can add ASSERT here.
+
+Cc: Eric Dong <eric.dong@intel.com>
+Cc: Liming Gao <liming.gao@intel.com>
+Contributed-under: TianoCore Contribution Agreement 1.0
+Signed-off-by: Dandan Bi <dandan.bi@intel.com>
+Reviewed-by: Eric Dong <eric.dong@intel.com>
+---
+Upstream-Status: Backport
+
+ MdeModulePkg/Library/UefiHiiLib/HiiLib.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/MdeModulePkg/Library/UefiHiiLib/HiiLib.c b/MdeModulePkg/Library/UefiHiiLib/HiiLib.c
+index 8579501..46ca7bc 100644
+--- a/MdeModulePkg/Library/UefiHiiLib/HiiLib.c
++++ b/MdeModulePkg/Library/UefiHiiLib/HiiLib.c
+@@ -2180,8 +2180,9 @@ InternalHiiIfrValueAction (
+   }\r
+   \r
+   StringPtr = ConfigAltResp;\r
+-  \r
+-  while (StringPtr != L'\0') {\r
++  ASSERT (StringPtr != NULL);\r
++\r
++  while (*StringPtr != L'\0') {\r
+     //\r
+     // 1. Find <ConfigHdr> GUID=...&NAME=...&PATH=...\r
+     //\r
+-- 
+1.9.1
+
index 73fdfc6239e77e637002b47fab1d0b7d9a86bf9b..9d988e9d414762900449f6108a98e1525d09e57a 100644 (file)
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/tianocore/edk2.git;branch=master \
        file://0002-ovmf-update-path-to-native-BaseTools.patch \
        file://0003-BaseTools-makefile-adjust-to-build-in-under-bitbake.patch \
        file://VfrCompile-increase-path-length-limit.patch \
+        file://0001-MdeModulePkg-UefiHiiLib-Fix-incorrect-comparison-exp.patch \
         "
 
 SRC_URI_append_class-target = " \