]> code.ossystems Code Review - openembedded-core.git/commitdiff
ppp: sync with OE (no package changes, PR bump)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 12:40:40 +0000 (12:40 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 25 Oct 2007 12:40:40 +0000 (12:40 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2964 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/ppp/ppp_2.4.3.bb

index 2897f638044fecf8b961bd03996a4695195f5ee4..71c68c2fb803031088bfe20afa5730e25640849b 100644 (file)
@@ -3,9 +3,9 @@ DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
 HOMEPAGE = "http://samba.org/ppp/"
 DEPENDS = "libpcap"
 LICENSE = "BSD GPLv2"
-PR = "r2"
+PR = "r3"
 
-SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-${PV}.tar.gz \
+SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
        file://makefile.patch;patch=1 \
        file://cifdefroute.patch;patch=1 \
        file://pppd-resolv-varrun.patch;patch=1 \
@@ -20,7 +20,7 @@ SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-${PV}.tar.gz \
        file://ip-down \
        file://08setupdns \
        file://92removedns"
-       
+
 SRC_URI_append_nylon = " file://ppp-tdbread.patch;patch=1"
 
 inherit autotools
@@ -28,6 +28,10 @@ inherit autotools
 EXTRA_OEMAKE = "STRIPPROG=${STRIP} MANDIR=${D}${datadir}/man/man8 INCDIR=${D}/usr/include LIBDIR=${D}/usr/lib/pppd/${PV} BINDIR=${D}/usr/sbin"
 EXTRA_OECONF = "--disable-strip"
 
+do_stage () {
+         make INCDIR=${STAGING_INCDIR} install-devel
+}
+
 do_install_append () {
        make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp
        mkdir -p ${D}${bindir}/ ${D}${sysconfdir}/init.d
@@ -43,15 +47,11 @@ do_install_append () {
        rm -rf ${D}/${mandir}/man8/man8
 }
 
-do_stage () {
-        make INCDIR=${STAGING_INCDIR} install-devel 
-}
-
 CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options"
 PACKAGES += "ppp-oa ppp-oe ppp-radius ppp-winbind ppp-minconn ppp-password ppp-tools"
 FILES_${PN}        = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd"
-FILES_${PN}-dbg += "/usr/lib/pppd/2.4.3/.debug"
 FILES_${PN}_nylon  = "/etc /usr/bin /usr/sbin/chat /usr/sbin/pppd /usr/sbin/tdbread"
+FILES_${PN}-dbg += "${libdir}/pppd/2.4.3/.debug"
 FILES_ppp-oa       = "/usr/lib/pppd/2.4.3/pppoatm.so"
 FILES_ppp-oe       = "/usr/sbin/pppoe-discovery /usr/lib/pppd/2.4.3/rp-pppoe.so"
 FILES_ppp-radius   = "/usr/lib/pppd/2.4.3/radius.so /usr/lib/pppd/2.4.3/radattr.so /usr/lib/pppd/2.4.3/radrealms.so"