]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: add powerpc to the compatible host and add ${TCLIBC}-dbg in RRECOMMENDS...
authorZhenhua Luo <b19537@freescale.com>
Fri, 6 Jan 2012 06:33:22 +0000 (14:33 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jan 2012 12:07:59 +0000 (12:07 +0000)
    1. add powerpc/powerpc64 into the compatible host list
    2. valgrind requires the non-stripped libraries of ${TCLIBC}, so add
       ${TCLIBC}-dbg into RRECOMMENDS for powerpc

Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/valgrind/valgrind_3.7.0.bb

index f4f3131c5800ef1bf0cfa7927788cbac0d825a7a..d2c44677f15cbe61e663daac3f8fc0cfc5473135 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
                     file://include/valgrind.h;beginline=1;endline=56;md5=aee56014c1dd64260a59fd4df38752f6 \
                     file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
 DEPENDS = "virtual/libx11"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
           file://fix_issue_caused_by_ccache.patch \
@@ -19,7 +19,7 @@ SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "a855fda56edf05614f099dca316d1775"
 SRC_URI[sha256sum] = "5d62c0330f1481fe2c593249192fa68ff454c19c34343978cc9ce91aa324cbf6"
 
-COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
+COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64).*-linux'
 
 inherit autotools
 
@@ -28,3 +28,5 @@ EXTRA_OEMAKE = "-w"
 PARALLEL_MAKE = ""
 
 FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug/*"
+RRECOMMENDS_${PN}_powerpc += "${TCLIBC}-dbg"
+RRECOMMENDS_${PN}_powerpc64 += "${TCLIBC}-dbg"