]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Fix for machines without zlib headers/library installed
authorRichard Purdie <rpurdie@linux.intel.com>
Sun, 24 May 2009 10:14:32 +0000 (11:14 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Sun, 24 May 2009 10:14:32 +0000 (11:14 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/qemu/qemu-git/zlibsearch.patch [new file with mode: 0644]
meta/packages/qemu/qemu-sdk_git.bb
meta/packages/qemu/qemu_git.bb

diff --git a/meta/packages/qemu/qemu-git/zlibsearch.patch b/meta/packages/qemu/qemu-git/zlibsearch.patch
new file mode 100644 (file)
index 0000000..6d7cf03
--- /dev/null
@@ -0,0 +1,13 @@
+Index: git/configure
+===================================================================
+--- git.orig/configure 2009-05-24 11:12:34.000000000 +0100
++++ git/configure      2009-05-24 11:12:55.000000000 +0100
+@@ -749,7 +749,7 @@
+ #include <zlib.h>
+ int main(void) { zlibVersion(); return 0; }
+ EOF
+-if $cc $ARCH_CFLAGS -o $TMPE ${OS_CFLAGS} $TMPC -lz > /dev/null 2> /dev/null ; then
++if $cc $CFLAGS $LDFLAGS $ARCH_CFLAGS -o $TMPE ${OS_CFLAGS} $TMPC -lz > /dev/null 2> /dev/null ; then
+     :
+ else
+     echo
index 9819d973ec6742ffbe8284f1327c9bd44c09a066..8a04d90dabaa4deec6891ea8e5a2e449724d0bfa 100644 (file)
@@ -1,6 +1,6 @@
 require qemu_git.bb
 require qemu-sdk.inc
 
-PR = "r1"
+PR = "r2"
 
 EXTRA_OECONF +="--target-list=arm-linux-user,arm-softmmu,i386-softmmu --disable-vnc-tls"
index fc6d9dc5536a26453d73d3c0fb13f3e9872e9275..b92ecf55201cd22618b1368b336d4e923ffc837c 100644 (file)
@@ -1,7 +1,7 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
 PV = "0.10.2+git${SRCREV}"
-PR = "r0"
+PR = "r1"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
 
@@ -18,7 +18,8 @@ SRC_URI = "\
     file://workaround_bad_futex_headers.patch;patch=1 \
     file://qemu-add-gl-host-code.patch;patch=1 \
     file://no-strip.patch;patch=1 \
-    file://fix-dirent.patch;patch=1"
+    file://fix-dirent.patch;patch=1 \
+    file://zlibsearch.patch;patch=1 "
 
 #    file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1