]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpam: use ${localstatedir} and ${sysconfdir} instead of /var and /etc
authorJavier Martinez Canillas <javier@dowhile0.org>
Sun, 5 Aug 2012 19:48:47 +0000 (21:48 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Aug 2012 13:36:53 +0000 (14:36 +0100)
It is considered good practice to use the build system provided
variables instead of directly specify hardcoded paths.

Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/pam/libpam_1.1.5.bb

index dd75d427ec0ff91f0c05e31d66f70aec90885b69..c035aafe14bfa92ae494dff9fff8ec25dd054084 100644 (file)
@@ -9,7 +9,7 @@ SECTION = "base"
 LICENSE = "GPLv2+ | BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-${PV}.tar.bz2 \
            file://99_pam \
@@ -79,9 +79,9 @@ do_install() {
        autotools_do_install
 
        # don't install /var/run when populating rootfs. Do it through volatile
-       rm -rf ${D}/var
+       rm -rf ${D}${localstatedir}
        install -d ${D}${sysconfdir}/default/volatiles
-       install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
+       install -m 0644 ${WORKDIR}/99_pam ${D}${sysconfdir}/default/volatiles
 
        install -d ${D}${sysconfdir}/pam.d/     
        install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/