]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: add /sbin to PATH
authorJuro Bystricky <juro.bystricky@intel.com>
Thu, 20 Oct 2016 16:54:23 +0000 (09:54 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Oct 2016 16:47:15 +0000 (17:47 +0100)
runqemu script fails with an error when executed in Build Appliance.

Typical use case:

$ bitbake core-image-minimal
$ runqemu qemux86

Observed error:

    runqemu - ERROR - In order for this script to dynamically infer paths
         ...snip...
         runqemu-ifup, runqemu-ifdown or ip not found

The error is caused by the fact that "ip" is located in /sbin, however /sbin is
not in user's ("builder") PATH. To fix this we add /sbin to PATH.
The simplest place to do this is in user's .bashrc.

[YOCTO#10434]

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/images/build-appliance-image_15.0.0.bb

index bb17486ed35c7d7103daa9c1e789d3c35206a02b..3ef464af3ff9e87e5aaf965a347a40341be5333c 100644 (file)
@@ -63,6 +63,9 @@ fakeroot do_populate_poky_src () {
        # Also save (for reference only) the actual SRCREV used to create this image
        echo "export BA_SRCREV=${SRCREV}" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
        echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+       echo "export PATH=$PATH:/sbin" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+       echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+
        echo "# If working behind a proxy and using the provided oe-git-proxy script" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
        echo "# you need to set ALL_PROXY based on your proxy settings." >> ${IMAGE_ROOTFS}/home/builder/.bashrc
        echo "# Example ALL_PROXY values:" >> ${IMAGE_ROOTFS}/home/builder/.bashrc