]> code.ossystems Code Review - openembedded-core.git/commitdiff
pkgconfig: Fix compile issues for non-native version
authorRichard Purdie <richard@openedhand.com>
Wed, 1 Aug 2007 19:11:11 +0000 (19:11 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 1 Aug 2007 19:11:11 +0000 (19:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2301 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pkgconfig/pkgconfig-native_0.22.bb
meta/packages/pkgconfig/pkgconfig.inc [new file with mode: 0644]
meta/packages/pkgconfig/pkgconfig_0.22.bb

index 507a74b7d97b0492c557601def69461ab8aab278..5a5423058ddb955654b591bafc9560bcca54f149 100644 (file)
@@ -1,7 +1,14 @@
 SECTION = "console/utils"
-require pkgconfig_${PV}.bb
+require pkgconfig.inc
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pkgconfig-${PV}"
 
 S = "${WORKDIR}/pkg-config-${PV}/"
 inherit native
 DEPENDS = ""
+
+do_configure() {
+        gnu-configize
+       libtoolize --force
+       oe_runconf
+}
+                        
\ No newline at end of file
diff --git a/meta/packages/pkgconfig/pkgconfig.inc b/meta/packages/pkgconfig/pkgconfig.inc
new file mode 100644 (file)
index 0000000..47c077a
--- /dev/null
@@ -0,0 +1,24 @@
+SECTION = "console/utils"
+DESCRIPTION = "pkg-config is a system for managing library \
+compile/link flags that works with automake and autoconf. \
+It replaces the ubiquitous *-config scripts you may have \
+seen with a single tool."
+HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
+           file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/pkg-config-${PV}/"
+
+inherit autotools
+
+acpaths = "-I ."
+do_configure_prepend () {
+       install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
+}
+
+do_stage_prepend() {
+       install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
+}
index 28cf2c53f8a7a6cf4caced111d38c1e96439aaa7..599e1c815ec40a48db23c21fbe2d51d4f0ef3a9f 100644 (file)
@@ -1,27 +1,3 @@
-SECTION = "console/utils"
-DESCRIPTION = "pkg-config is a system for managing library \
-compile/link flags that works with automake and autoconf. \
-It replaces the ubiquitous *-config scripts you may have \
-seen with a single tool."
-HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
-LICENSE = "GPL"
+require pkgconfig.inc
 
-SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
-           file://glibconfig-sysdefs.h"
-
-S = "${WORKDIR}/pkg-config-${PV}/"
-
-inherit autotools
-
-acpaths = "-I ."
-do_configure () {
-       install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
-       gnu-configize
-       libtoolize --force
-        oe_runconf
-}
-
-do_stage_prepend() {
-       install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
-
-}
+SRC_URI += "file://autofoo.patch;patch=1"