]> code.ossystems Code Review - openembedded-core.git/commitdiff
mtd-utils: Work with lzo 1.x for now
authorRichard Purdie <richard@openedhand.com>
Mon, 23 Jul 2007 16:33:20 +0000 (16:33 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 23 Jul 2007 16:33:20 +0000 (16:33 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2213 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/mtd/mtd-utils/lzo_1x.patch [new file with mode: 0644]
meta/packages/mtd/mtd-utils_1.0.0+git.bb

diff --git a/meta/packages/mtd/mtd-utils/lzo_1x.patch b/meta/packages/mtd/mtd-utils/lzo_1x.patch
new file mode 100644 (file)
index 0000000..b882d9f
--- /dev/null
@@ -0,0 +1,26 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -60,7 +60,7 @@ $(BUILDDIR)/mkfs.jffs2: $(BUILDDIR)/crc3
+                       $(BUILDDIR)/compr_zlib.o \
+                       $(BUILDDIR)/compr_lzo.o \
+                       $(BUILDDIR)/compr.o
+-      $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo2
++      $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo
+ $(BUILDDIR)/flash_eraseall: $(BUILDDIR)/crc32.o $(BUILDDIR)/flash_eraseall.o
+       $(CC) $(LDFLAGS) -o $@ $^
+Index: git/compr_lzo.c
+===================================================================
+--- git.orig/compr_lzo.c
++++ git/compr_lzo.c
+@@ -26,7 +26,7 @@
+ #include <string.h>
+ #include <asm/types.h>
+ #include <linux/jffs2.h>
+-#include <lzo/lzo1x.h>
++#include <lzo1x.h>
+ #include "compr.h"
+ extern int page_size;
index b7e242a33f33a597049b71c204c8fecb817e76ea..cfbd38c7148b5132d3bc7e2a5fc2e561bcf034ca 100644 (file)
@@ -3,11 +3,12 @@ SECTION = "base"
 DEPENDS = "zlib lzo"
 HOMEPAGE = "http://www.linux-mtd.infradead.org/"
 LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=master \
            file://add-exclusion-to-mkfs-jffs2-git.patch;patch=1 \
-          file://fix-ignoreerrors-git.patch;patch=1"
+          file://fix-ignoreerrors-git.patch;patch=1 \
+          file://lzo_1x.patch;patch=1"
 
 S = "${WORKDIR}/git/"