]> code.ossystems Code Review - openembedded-core.git/commitdiff
Potentially better scrollbar patch
authorRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 14:39:15 +0000 (14:39 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 14:39:15 +0000 (14:39 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2241 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch
meta/packages/gtk+/gtk+_2.6.10.bb

index 384d71b4fe4028b17041ff9659273fc03fd67c21..e3603d7700b080fb3b9a623b6c0e706a6beb7353 100644 (file)
@@ -2,16 +2,40 @@ Index: gtk/gtkrange.c
 ===================================================================
 --- gtk/gtkrange.c     (revision 18523)
 +++ gtk/gtkrange.c     (working copy)
-@@ -1979,8 +1979,12 @@
-       gtk_widget_queue_draw (GTK_WIDGET (range));
-       
-       /* This is so we don't lag the widget being scrolled. */
-+#if 0
-+      /* Disable this, the scroll bar lags a bit but the end result is that
-+         scrolling treeviews is *a lot* smoother. See GNOME #460534. */
-       if (GTK_WIDGET_REALIZED (range))
-         gdk_window_process_updates (GTK_WIDGET (range)->window, FALSE);
-+#endif
-     }
-   
-   /* Note that we don't round off to range->round_digits here.
+@@ -99,6 +99,8 @@
+   GtkSensitivityType lower_sensitivity;
+   GtkSensitivityType upper_sensitivity;
++
++  guint motion_idle;
+ };
+@@ -1721,6 +1723,16 @@
+                  &handled);
+ }
++static gboolean
++update_slider_position_idle (GtkRange *range)
++{
++  update_slider_position (range, range->layout->mouse_x,range->layout->mouse_y); 
++
++  range->layout->motion_idle = 0;
++
++  return FALSE;
++}
++
+ static void 
+ stop_scrolling (GtkRange *range)
+ {
+@@ -1860,8 +1872,8 @@
+   if (gtk_range_update_mouse_location (range))
+     gtk_widget_queue_draw (widget);
+-  if (range->layout->grab_location == MOUSE_SLIDER)
+-    update_slider_position (range, x, y);
++  if (range->layout->grab_location == MOUSE_SLIDER && !range->layout->motion_idle)
++    range->layout->motion_idle = g_idle_add ((GSourceFunc)update_slider_position_idle, range);
+   /* We handled the event if the mouse was in the range_rect */
+   return range->layout->mouse_location != MOUSE_OUTSIDE;
index d7199ef1dd19232b40d33298e8d9f40c0869cd2e..de22bbae75a45e44e913d50292f19009d9f97d5e 100644 (file)
@@ -1,6 +1,6 @@
 require gtk+.inc
 
-PR = "r12"
+PR = "r13"
 
 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
            file://no-demos.patch;patch=1 \