]> code.ossystems Code Review - openembedded-core.git/commitdiff
Reorganize the main exception handling so an attribute exception raised in the ui...
authorChris Larson <chris_larson@mentor.com>
Tue, 8 Jun 2010 19:28:36 +0000 (12:28 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 2 Jul 2010 14:41:35 +0000 (15:41 +0100)
(Bitbake rev: 49b8bab706c59e93287f8540187b62ba3ece0a11)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake

index 600cdadc9d9438eeb3c3d2cd32541cd760981347..9580784e55997ffeee517903c2e01c5e0030bc47 100755 (executable)
@@ -87,7 +87,7 @@ warnings.simplefilter("ignore", DeprecationWarning)
 #============================================================================#
 
 def main():
-    return_value = 0
+    return_value = 1
 
     parser = optparse.OptionParser(
         version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
@@ -201,13 +201,16 @@ Default BBFILES are the .bb files in the current directory.""")
         # suggest a fixed set this allows you to have flexibility in which
         # ones are available.
         uimodule = __import__("bb.ui", fromlist = [ui])
-        return_value = getattr(uimodule, ui).init(serverConnection.connection, serverConnection.events)
+        ui_init = getattr(uimodule, ui).init
     except AttributeError:
         print "FATAL: Invalid user interface '%s' specified. " % ui
         print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
-    except Exception, e:
-        print "FATAL: Unable to start to '%s' UI: %s" % (configuration.ui, e)
-        raise
+    else:
+        try:
+            return_value = ui_init(serverConnection.connection, serverConnection.events)
+        except Exception, e:
+            print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
+            raise
     finally:
         serverConnection.terminate()
         return return_value