]> code.ossystems Code Review - openembedded-core.git/commitdiff
nativesdk-packagegroup-sdk-host: reverse inherit order
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 16 Jan 2014 11:16:56 +0000 (13:16 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 Jan 2014 11:56:40 +0000 (11:56 +0000)
Currently, tow successive toolchain builds for different hosts, will
issue a warning:

WARNING: The recipe nativesdk-packagegroup-sdk-host is trying to install
files into a shared area when those files already exist. Those files and
their manifest location are:
   /ssd/work/yp1/build/tmp/deploy/ipk/all/nativesdk-packagegroup-sdk-host_1.0-r11_all.ipk
   Matched in manifest-x86_64-nativesdk-packagegroup-sdk-host.package_write_ipk
Please verify which package should provide the above files.

That's because packagegroup is manually inherited after nativesdk which
is usually a BBCLASSEXTEND operation, done last.

[YOCTO #5396]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb

index 9581ef38a52ba98de9be8da5ba748748dee71d14..1065f30b2be34ceeec223d5b1b7149ed27590866 100644 (file)
@@ -6,7 +6,7 @@ SUMMARY = "Host packages for the standalone SDK or external toolchain"
 PR = "r11"
 LICENSE = "MIT"
 
-inherit nativesdk packagegroup
+inherit packagegroup nativesdk
 
 PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"