]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: move links from lsbsetup to here
authorKang Kai <kai.kang@windriver.com>
Thu, 22 Nov 2012 03:25:47 +0000 (11:25 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 24 Nov 2012 15:12:05 +0000 (15:12 +0000)
Because package lsbsetup is dropped, move the links created for LSB test
to package lsb.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsb_4.1.bb

index 55ea2417837b6b02bff3e60f14d5fef3c19642c4..01368b334bd4b45f335f8aa0384e2f2543c897a8 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "LSB support for OpenEmbedded"
 SECTION = "console/utils"
 HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
 LICENSE = "GPLv2+"
-PR = "r0"
+PR = "r1"
 
 # lsb_release needs getopt
 RDEPENDS_${PN} += "util-linux"
@@ -73,6 +73,13 @@ do_install_append(){
            install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
        done
        install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
+
+       # creat links for LSB test
+       install -d ${D}/${libdir}/lsb
+       ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
+       ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
+       ln -sf ${sbindir}/sendmail ${D}/${libdir}/sendmail
+
        if [ "${TARGET_ARCH}" = "x86_64" ];then
               cd ${D}
                if [ "${baselib}" != "lib64" ]; then
@@ -105,4 +112,5 @@ do_install_append(){
 }
 FILES_${PN} += "/lib64 \
                 ${base_libdir}/lsb/* \
+               ${libdir}/sendmail \
                "