]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add gmp-sdk
authorRichard Purdie <richard@openedhand.com>
Mon, 6 Oct 2008 15:59:41 +0000 (15:59 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 6 Oct 2008 15:59:41 +0000 (15:59 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5419 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gmp/gmp-sdk.inc [new file with mode: 0644]
meta/packages/gmp/gmp-sdk_4.2.2.bb [new file with mode: 0644]

diff --git a/meta/packages/gmp/gmp-sdk.inc b/meta/packages/gmp/gmp-sdk.inc
new file mode 100644 (file)
index 0000000..a6b1533
--- /dev/null
@@ -0,0 +1,35 @@
+require gmp_${PV}.bb
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gmp-${PV}"
+S = "${WORKDIR}/gmp-${PV}"
+
+inherit sdk
+
+
+oe_runconf () {
+       if [ -x ${S}/configure ] ; then
+               cfgcmd="${S}/configure \
+                   --build=${BUILD_SYS} \
+                   --host=${HOST_SYS} \
+                   --prefix=${prefix} \
+                   --exec_prefix=${exec_prefix} \
+                   --bindir=${bindir} \
+                   --sbindir=${sbindir} \
+                   --libexecdir=${libexecdir} \
+                   --datadir=${datadir} \
+                   --sysconfdir=${sysconfdir} \
+                   --sharedstatedir=${sharedstatedir} \
+                   --localstatedir=${localstatedir} \
+                   --libdir=${libdir} \
+                   --includedir=${includedir} \
+                   --oldincludedir=${oldincludedir} \
+                   --infodir=${infodir} \
+                   --mandir=${mandir} \
+                       ${EXTRA_OECONF} \
+                   $@"
+               oenote "Running $cfgcmd..."
+               $cfgcmd || oefatal "oe_runconf failed" 
+       else
+               oefatal "no configure script found"
+       fi
+}
diff --git a/meta/packages/gmp/gmp-sdk_4.2.2.bb b/meta/packages/gmp/gmp-sdk_4.2.2.bb
new file mode 100644 (file)
index 0000000..286f800
--- /dev/null
@@ -0,0 +1,2 @@
+PV = "4.2.2"
+require gmp-sdk.inc