RCONFLICTS_${PN} = "atd"
RREPLACES_${PN} = "atd"
-PR = "r7"
+PR = "r0"
SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
file://configure.patch \
file://use-ldflags.patch \
- file://nonstripbinaries.patch \
file://fix_parallel_build_error.patch \
file://posixtm.c \
file://posixtm.h \
PAM_SRC_URI = "file://pam.conf.patch \
file://configure-add-enable-pam.patch"
-SRC_URI[md5sum] = "1e67991776148fb319fd77a2e599a765"
-SRC_URI[sha256sum] = "7c55c6ab4fbe8add9e68f31b2b0ebf3fe805c9a4e7cfb2623a3d8a4789cc18f3"
+SRC_URI[md5sum] = "1da61af6c29e323abaaf13ee1a8dad79"
+SRC_URI[sha256sum] = "3a8b90868d615d21a92f4986ea9a823886329af8fae8dd7ab4eed9b273bca072"
EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
--with-daemon_username=root \
inherit autotools
+PARALLEL_MAKE = ""
+
do_compile_prepend () {
cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/rcS.d
install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/atd
- ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at
+ ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at
cp -r ${D}/usr/doc/at ${D}${docdir}/
rm -rf ${D}/usr/doc
fi
done
}
-
-PARALLEL_MAKE = ""
+++ /dev/null
-Upstream-Status: Pending
-#Because remove nonrootinstall patch, the stripping of the binaries can not
-#be handled.
-#This patch is to handle the stripping of the binaries.
-#Mei Lei<lei.mei@intel.com> make this change
-diff --git at-3.1.12.orig/Makefile.in at-3.1.12/Makefile.in
-index dae6b7d..71a5d89 100644
---- at-3.1.12.orig/Makefile.in
-+++ at-3.1.12/Makefile.in
-@@ -97,14 +97,14 @@ install: all
- chmod 600 $(IROOT)$(LFILE)
- chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
-- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 -s at $(IROOT)$(bindir)
-+ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(IROOT)$(bindir)
- $(LN_S) -f at $(IROOT)$(bindir)/atq
- $(LN_S) -f at $(IROOT)$(bindir)/atrm
- $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
-- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
-+ $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
- cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
Upstream-Status: Pending
-# Ensure use of $LDFLAGS during build
-# Derived from an OE patch for at-3.1.8
+Ensure use of $LDFLAGS during build
+Derived from an OE patch for at-3.1.8
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
--- at-3.1.12.orig/Makefile.in 2009-11-23 07:11:52.000000000 -0800
+++ at-3.1.12/Makefile.in 2010-07-20 16:28:04.000000000 -0700
@@ -65,13 +65,13 @@