]> code.ossystems Code Review - openembedded-core.git/commitdiff
man-db: Fix reproducibility issue
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 2 Jan 2021 17:12:43 +0000 (17:12 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 Jan 2021 08:57:57 +0000 (08:57 +0000)
Executing a sequence like:

bitbake man-db
bitbake man-db -c clean
bitbake man-db -c package_write_deb -f

results in the ownership of files in the man-db package changing from "man/man"
to "6/12". This is due to base-passwd not being installed in the recipe
sysroot.

Add the missing dependency so even if a recipe "re-packages", the name
of the user/group is found and the packages are reproducible.

[YOCTO #14172]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/man-db/man-db_2.9.3.bb

index a28f77b75001248d843f2caf60bdc7306ac2db46..e8da92bd1951dbef24e4d96010f25427f93dc76b 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "fa5aa11ab0692daf737e76947f45669225db310b2801a5911bceb7551c
 
 DEPENDS = "libpipeline gdbm groff-native base-passwd"
 RDEPENDS_${PN} += "base-passwd"
+PACKAGE_WRITE_DEPS += "base-passwd"
 
 # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
 USE_NLS_libc-musl = "no"