]> code.ossystems Code Review - openembedded-core.git/commitdiff
bash: Fix CVE-2014-7169
authorKhem Raj <raj.khem@gmail.com>
Fri, 26 Sep 2014 20:21:19 +0000 (13:21 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Sep 2014 11:13:30 +0000 (12:13 +0100)
This is a followup patch to incomplete CVE-2014-6271 fix
code execution via specially-crafted environment

Change-Id: Ibb0a587ee6e09b8174e92d005356e822ad40d4ed
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/bash/bash-3.2.48/cve-2014-7169.patch [new file with mode: 0644]
meta/recipes-extended/bash/bash/cve-2014-7169.patch [new file with mode: 0644]
meta/recipes-extended/bash/bash_3.2.48.bb
meta/recipes-extended/bash/bash_4.3.bb

diff --git a/meta/recipes-extended/bash/bash-3.2.48/cve-2014-7169.patch b/meta/recipes-extended/bash/bash-3.2.48/cve-2014-7169.patch
new file mode 100644 (file)
index 0000000..2e734de
--- /dev/null
@@ -0,0 +1,16 @@
+Taken from http://www.openwall.com/lists/oss-security/2016/09/25/10
+
+Upstream-Status: Backport
+Index: bash-3.2.48/parse.y
+===================================================================
+--- bash-3.2.48.orig/parse.y   2008-04-29 18:24:55.000000000 -0700
++++ bash-3.2.48/parse.y        2014-09-26 13:07:31.956080056 -0700
+@@ -2503,6 +2503,8 @@
+   FREE (word_desc_to_read);
+   word_desc_to_read = (WORD_DESC *)NULL;
++  eol_ungetc_lookahead = 0;
++
+   last_read_token = '\n';
+   token_to_read = '\n';
+ }
diff --git a/meta/recipes-extended/bash/bash/cve-2014-7169.patch b/meta/recipes-extended/bash/bash/cve-2014-7169.patch
new file mode 100644 (file)
index 0000000..3c69121
--- /dev/null
@@ -0,0 +1,16 @@
+Taken from http://www.openwall.com/lists/oss-security/2016/09/25/10
+
+Upstream-Status: Backport
+Index: bash-4.3/parse.y
+===================================================================
+--- bash-4.3.orig/parse.y      2014-09-26 13:10:44.340080056 -0700
++++ bash-4.3/parse.y   2014-09-26 13:11:44.764080056 -0700
+@@ -2953,6 +2953,8 @@
+   FREE (word_desc_to_read);
+   word_desc_to_read = (WORD_DESC *)NULL;
++  eol_ungetc_lookahead = 0;
++
+   current_token = '\n';               /* XXX */
+   last_read_token = '\n';
+   token_to_read = '\n';
index 5849ed0169b98f49cf32fc9bef35c13a7c9e1e55..e6a04cd88852436a3531a8923199220a941b2066 100644 (file)
@@ -13,6 +13,7 @@ SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz;name=tarball \
            file://build-tests.patch \
            file://test-output.patch \
            file://cve-2014-6271.patch;striplevel=0 \
+           file://cve-2014-7169.patch \
            file://run-ptest \
           "
 
index febaf338fa76ca9952f6337310b9d2c251485907..69ddeccd35c43528c0ec437e3891bf6e9f6128a2 100644 (file)
@@ -10,6 +10,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
            file://build-tests.patch \
            file://test-output.patch \
            file://cve-2014-6271.patch;striplevel=0 \
+           file://cve-2014-7169.patch \
            file://run-ptest \
            "