]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: enable pci and CRYPTO_DEV_VIRTIO
authorBruce Ashfield <bruce.ashfield@windriver.com>
Sat, 22 Sep 2018 17:18:54 +0000 (13:18 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 16 Nov 2018 16:32:30 +0000 (16:32 +0000)
With recent kernels and the latest openssl we observe hangs when there
is not sufficient entropy in the system before crypto is used
(i.e. OpenVSwitch or openssh server).

This was mainly observed on qemuarm64, but can happen elsewhere. So
we enable CRYPTO_DEV_VIRTIO in the main virtio fragment and enable
PCI for qemuarm64 to ensure that entropy is available.

(From OE-Core rev: 8cc08e44cf3e969c124456d459c6c06a76cad018)

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
[Dropped 4.18 changes]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
meta/recipes-kernel/linux/linux-yocto_4.14.bb

index 605dc69589315ac13d30dabc31a4eb9d879acf14..24a2c593281eed8165eb59483f83377f997f04fd 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "c37a14708f5b618602f84f83f902346e055824c3"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
index 20be3c18f3e0b52ae1d6feda554f6f7aa7121c76..de220313013e081149defbaea5bd4500ea9bc8d6 100644 (file)
@@ -13,7 +13,7 @@ KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "3218be18094b7dfb4471b083c469452c8c7709ce"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index c931cf807076ad91718c48c8ab3658499a269411..7c97d53da164d05e8c66441a77dba3278e7bd5c3 100644 (file)
@@ -19,7 +19,7 @@ SRCREV_machine_qemux86 ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
 SRCREV_machine_qemux86-64 ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
 SRCREV_machine_qemumips64 ?= "f074d718736e95e8ed5460bf8e85c7e77ff7df87"
 SRCREV_machine ?= "78a16a4d8cfd58f91be412797aac248e811d083b"
-SRCREV_meta ?= "c35dd5cbbdb08dcc4fe35b8e9c0a62d1a157aeaf"
+SRCREV_meta ?= "46a547fa5195c2990e513ae3050376b7670e8287"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"