]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: add ssl to PACKAGECONFIG
authorJoão Henrique Ferreira de Freitas <joaohf@gmail.com>
Mon, 11 Aug 2014 02:09:56 +0000 (23:09 -0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 11 Aug 2014 10:16:34 +0000 (11:16 +0100)
This will allow curl run as nativesdk and fixes the following:

fatal: unable to access 'https://...': Protocol https not supported or disabled in libcurl

Signed-off-by: João Henrique Ferreira de Freitas <joaohf@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/curl/curl_7.37.1.bb

index 14bdff75dbdefe56a493f853d9d07ada916db75b..dc1d6a618fd260809ab2a6aae848b75f0888c1df 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
 
 DEPENDS = "zlib gnutls"
 DEPENDS_class-native = "zlib-native openssl-native"
-DEPENDS_class-nativesdk = "nativesdk-zlib"
+DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-openssl"
 
 SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
            file://pkgconfig_fix.patch \
@@ -25,7 +25,7 @@ inherit autotools pkgconfig binconfig multilib_header
 
 PACKAGECONFIG ??= "gnutls ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
 PACKAGECONFIG_class-native = "ipv6 ssl"
-PACKAGECONFIG_class-nativesdk = "ipv6"
+PACKAGECONFIG_class-nativesdk = "ipv6 ssl"
 PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
 PACKAGECONFIG[ssl] =  "--with-ssl, --without-ssl, ,"
 PACKAGECONFIG[gnutls] =  "--with-gnutls=${STAGING_LIBDIR}/../, --without-gnutls, gnutls,"