]> code.ossystems Code Review - openembedded-core.git/commitdiff
psplash: Remove pointless cat calls, promote to .sh initscript
authorRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 21:42:36 +0000 (21:42 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 19 Aug 2008 21:42:36 +0000 (21:42 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5083 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/psplash/files/psplash-init
meta/packages/psplash/psplash_svn.bb

index ea370d622b1ff80eb25288e9ac676d2f08f230cf..66c85e9335d8f16fd39a77caf74a62b1aa059e23 100755 (executable)
@@ -7,7 +7,8 @@
 # Default-Stop:
 ### END INIT INFO
 
-for x in $(cat /proc/cmdline); do
+read CMDLINE < /proc/cmdline
+for x in $CMDLINE; do
         case $x in
         psplash=false)
                echo "Boot splashscreen disabled" 
@@ -21,7 +22,7 @@ mount tmpfs -t tmpfs $TMPDIR -o,size=40k
 
 rotation=0
 if [ -e /etc/rotation ]; then
-       rotation=`cat /etc/rotation`
+       read rotation < /etc/rotation
 fi
 
 /usr/bin/psplash --angle $rotation &
index f2783990694dbec85229d1119a101bf0b03934b0..d46b051c6b52fc216ef789a5ef9cc429756aa3e5 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
 SECTION = "base"
 LICENSE = "GPL"
 PV = "0.0+svnr${SRCREV}"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
            file://psplash-init"
@@ -16,8 +16,8 @@ FILES_${PN} += "/mnt/.psplash"
 do_install_prepend() {
        install -d ${D}/mnt/.psplash/
        install -d ${D}${sysconfdir}/init.d/
-       install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+       install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
 }
 
-INITSCRIPT_NAME = "psplash"
+INITSCRIPT_NAME = "psplash.sh"
 INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."