]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtvorbis: Fix with libtool 2.2.2
authorRichard Purdie <richard@openedhand.com>
Tue, 15 Apr 2008 16:50:54 +0000 (16:50 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 15 Apr 2008 16:50:54 +0000 (16:50 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4276 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/libvorbis/libvorbis/m4.patch
meta/packages/libvorbis/libvorbis/makefile.patch [new file with mode: 0644]
meta/packages/libvorbis/libvorbis_1.0.1.bb

index 797a6b62a55d73b81cd552cc6c5a01fdcb4f95e2..a62f365c922d31265132ecaf3d890b741f14dde4 100644 (file)
@@ -1,5 +1,7 @@
---- libvorbis-1.0.1/vorbis.m4.orig     2002-08-14 20:25:39 +0200
-+++ libvorbis-1.0.1/vorbis.m4  2004-08-12 12:58:13 +0200
+Index: libvorbis-1.0.1/vorbis.m4
+===================================================================
+--- libvorbis-1.0.1.orig/vorbis.m4     2002-08-14 19:25:39.000000000 +0100
++++ libvorbis-1.0.1/vorbis.m4  2008-04-15 15:43:15.000000000 +0100
 @@ -6,7 +6,7 @@
  dnl XIPH_PATH_VORBIS([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
  dnl Test for libvorbis, and define VORBIS_CFLAGS and VORBIS_LIBS
@@ -9,3 +11,16 @@
  [dnl 
  dnl Get the cflags and libraries
  dnl
+Index: libvorbis-1.0.1/acinclude.m4
+===================================================================
+--- libvorbis-1.0.1.orig/acinclude.m4  2008-04-15 17:46:44.000000000 +0100
++++ libvorbis-1.0.1/acinclude.m4       2008-04-15 17:46:55.000000000 +0100
+@@ -8,7 +8,7 @@
+ dnl XIPH_PATH_OGG([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+ dnl Test for libogg, and define OGG_CFLAGS and OGG_LIBS
+ dnl
+-AC_DEFUN(XIPH_PATH_OGG,
++AC_DEFUN([XIPH_PATH_OGG],
+ [dnl 
+ dnl Get the cflags and libraries
+ dnl
diff --git a/meta/packages/libvorbis/libvorbis/makefile.patch b/meta/packages/libvorbis/libvorbis/makefile.patch
new file mode 100644 (file)
index 0000000..ecf41e3
--- /dev/null
@@ -0,0 +1,14 @@
+# Breaks with libtool 2.2.2
+
+Index: libvorbis-1.0.1/examples/Makefile.am
+===================================================================
+--- libvorbis-1.0.1.orig/examples/Makefile.am  2008-04-15 17:48:52.000000000 +0100
++++ libvorbis-1.0.1/examples/Makefile.am       2008-04-15 17:48:57.000000000 +0100
+@@ -7,7 +7,6 @@
+ noinst_PROGRAMS = decoder_example encoder_example chaining_example\
+               vorbisfile_example seeking_example
+-LDFLAGS = -all-static
+ LDADD = ../lib/libvorbis.la
+ decoder_example_SOURCES = decoder_example.c
index 70f279403fe99b65a637935ae52ce077a4ddcd4d..66e04ce5821b63a0cfce80ba2468ffe66b73188e 100644 (file)
@@ -4,10 +4,11 @@ DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
 that is free of intellectual property restrictions. libvorbis \
 is the main vorbis codec library."
 LICENSE = "BSD"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
-        file://m4.patch;patch=1"
+           file://makefile.patch;patch=1 \
+           file://m4.patch;patch=1"
 
 inherit autotools pkgconfig