]> code.ossystems Code Review - openembedded-core.git/commitdiff
bind: update libxml2 detection patch
authorRoss Burton <ross.burton@intel.com>
Thu, 7 May 2015 14:30:53 +0000 (15:30 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 9 May 2015 21:25:46 +0000 (22:25 +0100)
Refresh the libxml2 detection patch to directly call pkg-config instead of
attempting to use xml2-config, which will always return an error in OE.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch [new file with mode: 0644]
meta/recipes-connectivity/bind/bind/bind-add-crosscripts-search-path-for-xml2-config.patch [deleted file]
meta/recipes-connectivity/bind/bind_9.10.2.bb

diff --git a/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch b/meta/recipes-connectivity/bind/bind/0001-build-use-pkg-config-to-find-libxml2.patch
new file mode 100644 (file)
index 0000000..cb5251d
--- /dev/null
@@ -0,0 +1,42 @@
+xml2-config is disabled, so change the configure script to use pkgconfig to find
+libxml2.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+---
+ configure.in | 18 +++---------------
+ 1 file changed, 3 insertions(+), 15 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d566e1c..c9ef3a6 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2102,21 +2102,9 @@ case "$use_libxml2" in
+               DST_LIBXML2_INC=""
+               ;;
+       auto|yes)
+-              case X`(xml2-config --version) 2>/dev/null` in
+-              X2.[[6789]].*)
+-                      libxml2_libs=`xml2-config --libs`
+-                      libxml2_cflags=`xml2-config --cflags`
+-                      ;;
+-              *)
+-                      libxml2_libs=
+-                      libxml2_cflags=
+-                      ;;
+-              esac
+-              ;;
+-      *)
+-              if test -f "$use_libxml2/bin/xml2-config" ; then
+-                      libxml2_libs=`$use_libxml2/bin/xml2-config --libs`
+-                      libxml2_cflags=`$use_libxml2/bin/xml2-config --cflags`
++              if pkg-config --exists libxml-2.0 ; then
++                      libxml2_libs=`pkg-config libxml-2.0 --libs`
++                      libxml2_cflags=`pkg-config libxml-2.0 --cflags`
+               fi
+               ;;
+ esac
+-- 
+2.1.4
+
diff --git a/meta/recipes-connectivity/bind/bind/bind-add-crosscripts-search-path-for-xml2-config.patch b/meta/recipes-connectivity/bind/bind/bind-add-crosscripts-search-path-for-xml2-config.patch
deleted file mode 100644 (file)
index d24276c..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From 8fa549fe5390875d56f75e20d364394cd5ccf388 Mon Sep 17 00:00:00 2001
-From: Joe MacDonald <joe_macdonald@mentor.com>
-Date: Mon, 3 Nov 2014 21:52:02 -0500
-Subject: [PATCH] bind: add crosscripts search path for xml2-config
-
-The configure script was testing xml2-config from bin but in openembedded
-bin folder is not copied to sysroot so the test was failing. Added another 
-condition to test libxml-2.0.pc which is present in lib folder. Used pkg-config
-to get libs and cflags information.
-
-Upstream-Status: Inappropriate [ openembedded specific ]
-
-Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
----
- configure.in | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/configure.in b/configure.in
-index 3d04f4c..6032f67 100644
---- a/configure.in
-+++ b/configure.in
-@@ -1433,6 +1433,9 @@ case "$use_libxml2" in
-               if test -f "$use_libxml2/bin/xml2-config" ; then
-                       libxml2_libs=`$use_libxml2/bin/xml2-config --libs`
-                       libxml2_cflags=`$use_libxml2/bin/xml2-config --cflags`
-+              elif test -f "$use_libxml2/$base_libdir/pkgconfig/libxml-2.0.pc" ; then
-+                      libxml2_libs=`pkg-config libxml-2.0 --libs`
-+                      libxml2_cflags=`pkg-config libxml-2.0 --cflags`
-               fi
-               ;;
- esac
--- 
-1.9.1
-
index 21be397a9a9f52a1d0de6c3278dc3acc4e50cae7..c5bc242bf2c34ccf6e288fbc897bfd3f77e6575f 100644 (file)
@@ -16,9 +16,9 @@ SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
            file://named.service \
            file://bind9 \
            file://init.d-add-support-for-read-only-rootfs.patch \
-           file://bind-add-crosscripts-search-path-for-xml2-config.patch \
            file://bind-confgen-build-unix.o-once.patch \
-          "
+           file://0001-build-use-pkg-config-to-find-libxml2.patch \
+           "
 
 SRC_URI[md5sum] = "dca7a9967947bffa98547fca6130fc04"
 SRC_URI[sha256sum] = "6f9bb7908aa45c1edfa391e356fc0afc1ded175386cdefb6cf9e1289f7457a98"
@@ -34,8 +34,7 @@ EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \
 inherit autotools-brokensep update-rc.d systemd useradd pkgconfig
 
 PACKAGECONFIG ?= "libxml2"
-
-PACKAGECONFIG[libxml2] = "--with-libxml2=${STAGING_LIBDIR}/..,--with-libxml2=no,libxml2"
+PACKAGECONFIG[libxml2] = "--with-libxml2,--without-libxml2,libxml2"
 
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \