]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils/procps: Revert priority change since coreutils > busybox
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Dec 2015 16:34:04 +0000 (16:34 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Dec 2015 11:56:10 +0000 (11:56 +0000)
In 2ce514a394e1e062172bb097aa92a1792a0f8eaf, "coreutils: fix
ALTERNATIVE_PRIORITY conflict with procps and mktemp" the priority was
lowered from 100 to 30. Unfortunately this lowered coreutils past
busybox which means busybox was ending up in our SDK images. This isn't
what users expect.

1c0cfffee21e99a7356c9046c86628bc0acf654c raises the priority of mktemp
to 200, do the same for procps and make the system consistent.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/coreutils/coreutils_8.24.bb
meta/recipes-extended/procps/procps_3.3.10.bb

index b6ecc054b4bd9a7c2e5a2461ca072b904771940b..f042346241dac6a457b131be8709b613242a54c5 100644 (file)
@@ -91,7 +91,7 @@ do_install_append_class-native(){
 
 inherit update-alternatives
 
-ALTERNATIVE_PRIORITY = "30"
+ALTERNATIVE_PRIORITY = "100"
 ALTERNATIVE_${PN} = "lbracket ${bindir_progs} ${base_bindir_progs} ${sbindir_progs} base64 mktemp df"
 ALTERNATIVE_${PN}-doc = "base64.1 mktemp.1 df.1 lbracket.1 groups.1 kill.1 uptime.1 stat.1"
 
index dcfaba71f2ec07202f9dee7f6cb47009ae59b52a..e474f5b5b4e4673395ed1dfd2e8b6ffef1cf14d4 100644 (file)
@@ -49,7 +49,7 @@ bindir_progs = "free pkill pmap pgrep pwdx skill snice top uptime"
 base_bindir_progs += "kill pidof ps watch"
 base_sbindir_progs += "sysctl"
 
-ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_PRIORITY = "200"
 
 ALTERNATIVE_${PN} = "${bindir_progs} ${base_bindir_progs} ${base_sbindir_progs}"