]> code.ossystems Code Review - openembedded-core.git/commitdiff
buildtools-tarball: Change the way the SDK is sanitized
authorMark Hatle <mark.hatle@windriver.com>
Mon, 24 Jun 2013 14:47:15 +0000 (09:47 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Jun 2013 16:43:43 +0000 (17:43 +0100)
The previous method of shrinking down the scale of the environment-setup
file would not work properly when the target is configured with multilibs.

In addition, the configured machine name and similar settings could leak
into the SDK naming.  This was resolved by clearing the SDK generated
files and generating our own custom files.

Note, the name of the environment-setup now is suffixed with the SDK_SYS.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/meta/buildtools-tarball.bb

index 7a91c6b6ac6ebeb3e7853e88d7091a43347ef8e9..387db753738fec9c1e091e6ad63b38831d50448d 100644 (file)
@@ -48,8 +48,15 @@ inherit meta
 inherit populate_sdk
 
 create_sdk_files_append () {
-       rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config*
-       
-       cat ${SDK_OUTPUT}/${SDKPATH}/environment-setup* | grep " PATH=\|OECORE_NATIVE_SYSROOT" > ${WORKDIR}/envtmp
-       mv ${WORKDIR}/envtmp ${SDK_OUTPUT}/${SDKPATH}/environment-setup*
+       rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
+       rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
+       rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
+
+       # Generate new (mini) sdk-environment-setup file
+       script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
+       touch $script
+       echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
+       echo 'export OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
+
+       toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
 }