]> code.ossystems Code Review - openembedded-core.git/commitdiff
npth: Upgrade to 1.1
authorSaul Wold <sgw@linux.intel.com>
Mon, 10 Nov 2014 21:59:03 +0000 (13:59 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Dec 2014 12:22:40 +0000 (12:22 +0000)
Add patch for adding pkgconfig file.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/npth/npth/pkgconfig.patch [new file with mode: 0644]
meta/recipes-support/npth/npth_1.1.bb [moved from meta/recipes-support/npth/npth_1.0.bb with 74% similarity]

diff --git a/meta/recipes-support/npth/npth/pkgconfig.patch b/meta/recipes-support/npth/npth/pkgconfig.patch
new file mode 100644 (file)
index 0000000..55d12c2
--- /dev/null
@@ -0,0 +1,48 @@
+Added npth pkgconfig file
+
+Upstream-Status: Incompatible [oe-core specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+Index: npth-1.1/src/npth.pc.in
+===================================================================
+--- /dev/null
++++ npth-1.1/src/npth.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: npth
++Description: a new portable posix threading library
++Version: @VERSION@
++Libs: -L${libdir} -lnpth
++Cflags: -I${includedir}
+Index: npth-1.1/src/Makefile.am
+===================================================================
+--- npth-1.1.orig/src/Makefile.am
++++ npth-1.1/src/Makefile.am
+@@ -27,8 +27,10 @@
+ # License along with this program; if not, see <http://www.gnu.org/licenses/>.
+ ## Process this file with automake to produce Makefile.in
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = npth.pc
+-EXTRA_DIST = libnpth.vers
++EXTRA_DIST = libnpth.vers npth.pc
+ #          versioninfo.rc.in
+ nodist_include_HEADERS = npth.h
+Index: npth-1.1/configure.ac
+===================================================================
+--- npth-1.1.orig/configure.ac
++++ npth-1.1/configure.ac
+@@ -337,6 +337,7 @@ src/Makefile
+ w32/Makefile
+ tests/Makefile])
+ AC_CONFIG_FILES(npth-config, chmod +x npth-config)
++AC_CONFIG_FILES([src/npth.pc])
+ AC_OUTPUT
+ echo "
similarity index 74%
rename from meta/recipes-support/npth/npth_1.0.bb
rename to meta/recipes-support/npth/npth_1.1.bb
index 3356ba06b0306a345ca0870625e3018c08d1b138..72a194e784d0535c4bfd8bf4a90727df3c285897 100644 (file)
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = "\
     file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6\
     "
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/npth/npth-${PV}.tar.bz2 \
+           file://pkgconfig.patch \
           "
 
-SRC_URI[md5sum] = "36869bf10378ea08c155cd5c3580a1dd"
-SRC_URI[sha256sum] = "9ad49de376310effab7fdad69581054b0fa9023d062032d06e73058146c8f76e"
+SRC_URI[md5sum] = "aaffc8ef3e955ab50a1905809f268a23"
+SRC_URI[sha256sum] = "896c561eb2ec8da35f11828fb04a3fbff12d41ff657c799056d7dc4a66e5df7f"
 
 BINCONFIG = "${bindir}/npth-config"