]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/3.8: allow kernel feature _appends to be overriden
authorBruce Ashfield <bruce.ashfield@windriver.com>
Tue, 26 Mar 2013 14:46:32 +0000 (07:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Mar 2013 17:48:06 +0000 (17:48 +0000)
It was pointed out that the current way the KERNEL_FEATURES variable
is appended in the base linux-yocto recipe doesn't allow the appended
features to be prevented in a layer without using python code and
a recipe finalize hook.

To allow easier overriding of 'extra' or 'optional' features that are
defined in the linux-yocto recipe, we create a KERNEL_EXTRA_FEATURES
variable. This variable can be set in a layer to define extra features
or cleared to prevent the recipe's extra features from being appended
to the core functionality.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto_3.8.bb

index b395e454882bdfa462fff4c8fe80c65a386ba576..f29675aab26fb2d1cb09ea24fe3a97ddd74aa40c 100644 (file)
@@ -23,8 +23,7 @@ KMETA = "meta"
 COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
 
 # Functionality flags
-KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
-KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append_qemux86=" ${KERNEL_EXTRA_FEATURES} cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" ${KERNEL_EXTRA_FEATURES} cfg/sound.scc"
 KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"