]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygtk: upgrade from 2.10.4 to 2.17.0
authorNitin A Kamble <nitin.a.kamble@intel.com>
Wed, 7 Jul 2010 11:40:08 +0000 (04:40 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 16 Jul 2010 15:25:16 +0000 (16:25 +0100)
Rebased this patch to the newer code
nodocs.patch

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/packages/python/python-pygtk/nodocs.patch
meta/packages/python/python-pygtk_2.17.0.bb [moved from meta/packages/python/python-pygtk_2.10.4.bb with 60% similarity]

index 9b2387e959263e32df01ed03ebf0b23b33cc29c9..c3581043c325c461e409f1f44d8aa9cc3bc9a055 100644 (file)
@@ -1,13 +1,13 @@
-Index: pygtk-2.10.4/Makefile.am
+Index: pygtk-2.17.0/Makefile.am
 ===================================================================
---- pygtk-2.10.4.orig/Makefile.am
-+++ pygtk-2.10.4/Makefile.am
+--- pygtk-2.17.0.orig/Makefile.am
++++ pygtk-2.17.0/Makefile.am
 @@ -4,7 +4,7 @@ if BUILD_GTK
    GTK_SUBDIR = gtk
  endif
  
--SUBDIRS = codegen . $(GTK_SUBDIR) examples tests docs
-+SUBDIRS = codegen . $(GTK_SUBDIR) examples tests
+-SUBDIRS = . $(GTK_SUBDIR) examples tests docs
++SUBDIRS = . $(GTK_SUBDIR) examples tests
  
  PLATFORM_VERSION = 2.0
  
similarity index 60%
rename from meta/packages/python/python-pygtk_2.10.4.bb
rename to meta/packages/python/python-pygtk_2.17.0.bb
index 00abd048e2e7e37856447412462db568089b2d6c..ef63b51038809664e28dd8db7e908851df1a2ffe 100644 (file)
@@ -1,6 +1,6 @@
-DESCRIPTION = "Python GTK+ 2.10.x Bindings"
+DESCRIPTION = "Python GTK+ 2.17.x Bindings"
 SECTION = "devel/python"
-# needs gtk+ 2.10.x
+# needs gtk+ 2.17.x
 DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
 RDEPENDS = "python-shell python-pycairo python-pygobject"
 PROVIDES = "python-pygtk2"
@@ -8,17 +8,14 @@ SRCNAME = "pygtk"
 LICENSE = "LGPL"
 PR = "ml8.2"
 
-SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar.bz2 \
-           file://fix-gtkunixprint.patch;patch=1 \
-           file://prevent_to_get_display_during_import.patch;patch=1 \
-           file://nodocs.patch;patch=1 \
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar.bz2 \
+           file://fix-gtkunixprint.patch \
+           file://prevent_to_get_display_during_import.patch \
+           file://nodocs.patch \
            file://acinclude.m4"
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-EXTRA_OECONF = "\
-  --disable-docs \
-  --with-python-includes=${STAGING_INCDIR}/../ \
-"
+EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
 
 inherit autotools pkgconfig distutils-base
 
@@ -37,15 +34,9 @@ do_install_append() {
 require fix-path.inc
 
 PACKAGES =+ "${PN}-demo"
-FILES_${PN}-demo = "\
-  ${bindir}/pygtk-demo \
-  ${libdir}/pygtk \
-"
+FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk "
 RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
 
 # todo: revamp packaging, package demo seperatly
-FILES_${PN}-dev += "\
-  ${libdir}/pygtk/2.0 \
-  ${bindir}/pygtk-* \
-  ${datadir}/pygtk/2.0"
+FILES_${PN}-dev += " ${libdir}/pygtk/2.0 ${bindir}/pygtk-* ${datadir}/pygtk/2.0"