-Index: pygtk-2.10.4/Makefile.am
+Index: pygtk-2.17.0/Makefile.am
===================================================================
---- pygtk-2.10.4.orig/Makefile.am
-+++ pygtk-2.10.4/Makefile.am
+--- pygtk-2.17.0.orig/Makefile.am
++++ pygtk-2.17.0/Makefile.am
@@ -4,7 +4,7 @@ if BUILD_GTK
GTK_SUBDIR = gtk
endif
--SUBDIRS = codegen . $(GTK_SUBDIR) examples tests docs
-+SUBDIRS = codegen . $(GTK_SUBDIR) examples tests
+-SUBDIRS = . $(GTK_SUBDIR) examples tests docs
++SUBDIRS = . $(GTK_SUBDIR) examples tests
PLATFORM_VERSION = 2.0
-DESCRIPTION = "Python GTK+ 2.10.x Bindings"
+DESCRIPTION = "Python GTK+ 2.17.x Bindings"
SECTION = "devel/python"
-# needs gtk+ 2.10.x
+# needs gtk+ 2.17.x
DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
RDEPENDS = "python-shell python-pycairo python-pygobject"
PROVIDES = "python-pygtk2"
LICENSE = "LGPL"
PR = "ml8.2"
-SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar.bz2 \
- file://fix-gtkunixprint.patch;patch=1 \
- file://prevent_to_get_display_during_import.patch;patch=1 \
- file://nodocs.patch;patch=1 \
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar.bz2 \
+ file://fix-gtkunixprint.patch \
+ file://prevent_to_get_display_during_import.patch \
+ file://nodocs.patch \
file://acinclude.m4"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-EXTRA_OECONF = "\
- --disable-docs \
- --with-python-includes=${STAGING_INCDIR}/../ \
-"
+EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
inherit autotools pkgconfig distutils-base
require fix-path.inc
PACKAGES =+ "${PN}-demo"
-FILES_${PN}-demo = "\
- ${bindir}/pygtk-demo \
- ${libdir}/pygtk \
-"
+FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk "
RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
# todo: revamp packaging, package demo seperatly
-FILES_${PN}-dev += "\
- ${libdir}/pygtk/2.0 \
- ${bindir}/pygtk-* \
- ${datadir}/pygtk/2.0"
+FILES_${PN}-dev += " ${libdir}/pygtk/2.0 ${bindir}/pygtk-* ${datadir}/pygtk/2.0"