]> code.ossystems Code Review - openembedded-core.git/commitdiff
sstate.bbclass: remove dependencies of SSTATE_EXTRAPATHWILDCARD
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 16 Jan 2019 06:27:08 +0000 (14:27 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Jan 2019 11:08:29 +0000 (11:08 +0000)
There might be do_cleansstate errors sometimes:
ERROR: When reparsing
/path/to/meta/recipes-devtools/quilt/quilt-native_0.65.bb.do_cleansstate,
the basehash value changed from
b4dbcb956a32ed4c3f58b7971717907bfc03bb21f3b140fa97f7765ee695f4d0 to
c8307418a671686349b73efbd51c5c82c897a88707a759ddb22fd95baa5df2ba. The metadata
is not deterministic and this needs to be fixed.

The stable reproducer is:
- Initial a fresh build, this is a must, otherwise we may can't reproduce it
  $ . oe-init-build-env build
  $ bitbake quilt-native -ccleansstate

This is because uninative.bbclass resets NATIVELSBSTRING from distro (e.g.,
ubuntu) to universal, remove dependencies of SSTATE_EXTRAPATHWILDCARD as
SSTATE_EXTRAPATH did can fix the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/sstate.bbclass

index 482ffa83f98d3ed97da99de487b942e86a12a76b..763fce07f95a8e9ad3ac228a53ab626f7e021dfc 100644 (file)
@@ -23,6 +23,7 @@ PV[vardepvalue] = "${PV}"
 # We don't want the sstate to depend on things like the distro string
 # of the system, we let the sstate paths take care of this.
 SSTATE_EXTRAPATH[vardepvalue] = ""
+SSTATE_EXTRAPATHWILDCARD[vardepvalue] = ""
 
 # For multilib rpm the allarch packagegroup files can overwrite (in theory they're identical)
 SSTATE_DUPWHITELIST = "${DEPLOY_DIR}/licenses/"