]> code.ossystems Code Review - openembedded-core.git/commitdiff
distcc: fix makefile parameter order
authorDongxiao Xu <dongxiao.xu@intel.com>
Tue, 26 Jul 2011 00:26:08 +0000 (08:26 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 14:44:23 +0000 (15:44 +0100)
When linking with gcc, the parameter is read from left to write, if *.o
calls a function contained in libxxx, the parameter order should be

"gcc ... *.o -lxxx".

This commit fixes the problem in distcc.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-devtools/distcc/distcc_2.18.3.bb
meta/recipes-devtools/distcc/files/makefile-param-order.patch [new file with mode: 0644]

index ece1b02105628466723e4a5200f264e9f89ed3fb..e474cce4c707953d2aed2668dd5db6a3ef3e38ae 100644 (file)
@@ -4,7 +4,7 @@ compilation of C/C++/ObjC code across machines on a network."
 SECTION = "devel"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r6"
+PR = "r7"
 
 DEPENDS = "avahi ${GTKDEP}"
 GTKDEP_libc-uclibc = ""
@@ -16,6 +16,7 @@ RRECOMMENDS_${PN} = "avahi-daemon"
 # http://0pointer.de/public/distcc-avahi.patch
 SRC_URI = "http://distcc.googlecode.com/files/${PN}-${PV}.tar.bz2 \
            file://distcc-avahi.patch \   
+           file://makefile-param-order.patch \
           file://default \
           file://distccmon-gnome.desktop \
           file://distcc"
diff --git a/meta/recipes-devtools/distcc/files/makefile-param-order.patch b/meta/recipes-devtools/distcc/files/makefile-param-order.patch
new file mode 100644 (file)
index 0000000..fc57414
--- /dev/null
@@ -0,0 +1,20 @@
+distcc: Put the "-lLIB" parameter in the end of the gcc command.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+Upstream-Status: Pending
+
+diff -ruN distcc-2.18.3-orig/Makefile.in distcc-2.18.3/Makefile.in
+--- distcc-2.18.3-orig/Makefile.in     2011-07-25 16:43:21.000000000 +0800
++++ distcc-2.18.3/Makefile.in  2011-07-25 16:45:39.000000000 +0800
+@@ -378,8 +378,8 @@
+ distccmon-gnome@EXEEXT@: $(mon_obj) $(gnome_obj)
+       $(CC) -o $@ $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(LIBS)    \
+-              $(GNOME_CFLAGS) $(GNOME_LIBS)                   \
+-              $(mon_obj) $(gnome_obj)
++              $(GNOME_CFLAGS)                                 \
++              $(mon_obj) $(gnome_obj) $(GNOME_LIBS)
+ ## Dist targets