]> code.ossystems Code Review - openembedded-core.git/commitdiff
gst-ffmpeg: Patch out beos bits from ffmpeg which break libtool 2.2.2
authorRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 23:03:34 +0000 (23:03 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 14 Apr 2008 23:03:34 +0000 (23:03 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4263 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch [new file with mode: 0644]
meta/packages/gstreamer/gst-ffmpeg_0.10.1.bb

diff --git a/meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch b/meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch
new file mode 100644 (file)
index 0000000..9ffcaff
--- /dev/null
@@ -0,0 +1,55 @@
+The AC_LANG sections upset libtool 2.2.2, easiest fix is to remove them.
+Using a .cpp file in a Makefile means configure.ac must use AC_PROG_CXX
+so patch out the section from the makefile too.
+
+RP - 14/4/08
+
+Index: gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac
+===================================================================
+--- gst-ffmpeg-0.10.1.orig/gst-libs/ext/ffmpeg/configure.ac    2008-04-14 23:55:25.000000000 +0100
++++ gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac 2008-04-14 23:56:18.000000000 +0100
+@@ -742,26 +742,7 @@
+ dnl Beos Audio
+ AC_FF_ALLOW_DISABLE(CONFIG_AUDIO_BEOS, audio-beos, BeOS audio support,[
+-  if test x$TARGET_OS = xbeos; then
+-    AC_LANG_CPLUSPLUS
+-    AC_CHECK_HEADER(SoundPlayer.h,[
+-      OLD_CXXFLAGS="$CXXFLAGS"
+-      CXXFLAGS="$CXXFLAGS -lbe -lmedia"
+-      AC_MSG_CHECKING(For BeOS audio libraries)
+-      AC_TRY_COMPILE([
+-#include <Application.h>
+-#include <SoundPlayer.h>
+-        ],[
+-          BSoundPlayer *p = new BSoundPlayer(NULL,NULL,NULL);
+-        ],[ CONFIG_AUDIO_BEOS=yes && AC_MSG_RESULT(yes) ],[
+-          CONFIG_AUDIO_BEOS=no && AC_MSG_RESULT(no)
+-      ])
+-      CXXFLAGS="$OLD_CXXFLAGS"
+-    ], CONFIG_AUDIO_BEOS=no)
+-    AC_LANG_C
+-  else
+     CONFIG_AUDIO_BEOS=no
+-  fi
+ ])
+ dnl Check for freetype2, used in vook/libdrawtext.so
+Index: gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/libavformat/Makefile.am
+===================================================================
+--- gst-ffmpeg-0.10.1.orig/gst-libs/ext/ffmpeg/libavformat/Makefile.am 2008-04-14 23:58:44.000000000 +0100
++++ gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/libavformat/Makefile.am      2008-04-14 23:58:55.000000000 +0100
+@@ -24,13 +24,6 @@
+ audiooss_SRC = audio.c
+ endif
+-if CONFIG_AUDIO_BEOS
+-audiobeos_SRC = beosaudio.cpp
+-audiobeos_LIBS = \
+-      -lbe \
+-      -lmedia
+-endif
+-
+ if CONFIG_VIDEO4LINUX
+ v4l_SRC = grab.c v4l2.c
+ endif
index 1ffffc4919fbb84264a0971cc0973c3808a8c5ad..f6ff3270b35ab33f57d065e0d47db13fa42caf30 100644 (file)
@@ -4,11 +4,12 @@ PRIORITY = "optional"
 LICENSE = "LGPL"
 HOMEPAGE = "http://www.gstreamer.net/"
 DEPENDS = "gstreamer zlib gst-plugins-base"
-PR = "r2"
+PR = "r3"
 
 inherit autotools pkgconfig
 
 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
+           file://no_beos.patch;patch=1 \
            file://configure_fix.patch;patch=1"
 
 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"