]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: stage /etc/skel
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>
Thu, 22 Oct 2015 11:58:18 +0000 (14:58 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Nov 2015 07:56:49 +0000 (07:56 +0000)
Having skel in the staging area lets other recipes access these files.
For ex. recipes inheriting useradd, if passing "-m" to USERADD_PARAM,
.bashrc and .profile are put automatically in $HOME, as expected.

Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/base-files/base-files_3.0.14.bb

index e16fe722b8a5710c313c0c5ed90aadc2a060ef69..b71d5c5341d31bf9f7f5ddad40dab1c7ddcf4a55 100644 (file)
@@ -167,6 +167,10 @@ do_install_append_linuxstdbase() {
         done
 }
 
+sysroot_stage_all_append () {
+       sysroot_stage_dir ${D}${sysconfdir}/skel ${SYSROOT_DESTDIR}${sysconfdir}/skel
+}
+
 PACKAGES = "${PN}-doc ${PN} ${PN}-dev ${PN}-dbg"
 FILES_${PN} = "/"
 FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"