]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: build fix for MIPS + musl libc
authorAndre McCurdy <armccurdy@gmail.com>
Wed, 10 Feb 2016 17:43:33 +0000 (17:43 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Feb 2016 12:27:24 +0000 (12:27 +0000)
The MIPS specific header <sgidefs.h> is provided by glibc and uclibc
but not by musl. Regardless of the libc, the kernel headers provide
<asm/sgidefs.h> which provides the same definitions, so use that
instead.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/strace/strace/use-asm-sgidefs.h.patch [new file with mode: 0644]
meta/recipes-devtools/strace/strace_4.11.bb

diff --git a/meta/recipes-devtools/strace/strace/use-asm-sgidefs.h.patch b/meta/recipes-devtools/strace/strace/use-asm-sgidefs.h.patch
new file mode 100644 (file)
index 0000000..db83d11
--- /dev/null
@@ -0,0 +1,51 @@
+From 2995245d7e3f46e8b3995002995ebd28beca7d55 Mon Sep 17 00:00:00 2001
+From: Andre McCurdy <armccurdy@gmail.com>
+Date: Fri, 5 Feb 2016 14:00:00 -0800
+Subject: [PATCH] use <asm/sgidefs.h>
+
+Build fix for MIPS with musl libc.
+
+The MIPS specific header <sgidefs.h> is provided by glibc and uclibc
+but not by musl. Regardless of the libc, the kernel headers provide
+<asm/sgidefs.h> which provides the same definitions, so use that
+instead.
+
+Upstream-Status: Pending
+
+Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
+---
+ configure.ac | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1524b9b..287e03d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -196,20 +196,20 @@ AC_SUBST(arch_mx32)
+ if test "$arch" = mips; then
+       AC_CACHE_CHECK([for _MIPS_SIM], [st_cv__MIPS_SIM],
+                      [AC_COMPUTE_INT([st_cv__MIPS_SIM], [_MIPS_SIM],
+-                                     [#include <sgidefs.h>],
++                                     [#include <asm/sgidefs.h>],
+                                      [AC_MSG_ERROR([_MIPS_SIM cannot be determined])])])
+       AC_CACHE_CHECK([for MIPS ABI], [st_cv_mips_abi],
+               [AC_COMPILE_IFELSE(
+-                      [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
++                      [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
+                                        [[int i[_MIPS_SIM == _MIPS_SIM_ABI32 ? 1 : - 1];]])],
+                       [st_cv_mips_abi=o32],
+               [AC_COMPILE_IFELSE(
+-                      [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
++                      [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
+                                        [[int i[_MIPS_SIM == _MIPS_SIM_NABI32 ? 1 : - 1];]])],
+                       [st_cv_mips_abi=n32],
+               [AC_COMPILE_IFELSE(
+-                      [AC_LANG_PROGRAM([[#include <sgidefs.h>]],
++                      [AC_LANG_PROGRAM([[#include <asm/sgidefs.h>]],
+                                        [[int i[_MIPS_SIM == _MIPS_SIM_ABI64 ? 1 : - 1];]])],
+                       [st_cv_mips_abi=n64],
+                       [st_cv_mips_abi=unknown])])])])
+-- 
+1.9.1
+
index a72a1f9c240eb524fc9b3cc42ea2e03db7c0a31f..95d13e6bb9eb545148ee1a857d572ad04fc7ac3a 100644 (file)
@@ -8,6 +8,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
            file://disable-git-version-gen.patch \
            file://more-robust-test-for-m32-mx32-compile-support.patch \
            file://update-gawk-paths.patch \
+           file://use-asm-sgidefs.h.patch \
            file://Makefile-ptest.patch \
            file://run-ptest \
           "