]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc: Upgrade to latest tip of master
authorKhem Raj <raj.khem@gmail.com>
Thu, 7 Jul 2016 18:08:27 +0000 (11:08 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Jul 2016 22:10:02 +0000 (23:10 +0100)
- libc-package.bbclass: Do not use --old-style
  This option has been dropped from latest glibc

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/libc-package.bbclass
meta/recipes-core/glibc/cross-localedef-native_2.24.bb
meta/recipes-core/glibc/glibc_2.24.bb

index c1781c64b48e9cbeb6e2ab83c150911554ead782..8c99d6113dc301ee745d882e07feed2d80b558d7 100644 (file)
@@ -262,7 +262,7 @@ python package_do_split_gconvs () {
                 bb.error("locale_arch_options not found for target_arch=" + target_arch)
                 raise bb.build.FuncFailed("unknown arch:" + target_arch + " for locale_arch_options")
 
-            localedef_opts += " --force --old-style --no-archive --prefix=%s \
+            localedef_opts += " --force  --no-archive --prefix=%s \
                 --inputfile=%s/%s/i18n/locales/%s --charmap=%s %s/%s" \
                 % (treedir, treedir, datadir, locale, encoding, outputpath, name)
 
@@ -270,7 +270,7 @@ python package_do_split_gconvs () {
                 (path, i18npath, gconvpath, localedef_opts)
         else: # earlier slower qemu way 
             qemu = qemu_target_binary(d) 
-            localedef_opts = "--force --old-style --no-archive --prefix=%s \
+            localedef_opts = "--force --no-archive --prefix=%s \
                 --inputfile=%s/i18n/locales/%s --charmap=%s %s" \
                 % (treedir, datadir, locale, encoding, name)
 
index 79c31326e53845a2be328dfd2a69a37e49999d89..104e38bceb67757b36be8cca56e1f74e1581a3ab 100644 (file)
@@ -22,7 +22,7 @@ GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
 SRCBRANCH ?= "master"
 UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
 
-SRCREV_glibc ?= "1ac3eaa6bcc473a56340c24511786ff48a91293e"
+SRCREV_glibc ?= "d461c9682d4954076f9ee9e07be903c2eef8e73b"
 SRCREV_localedef ?= "29869b6dc11427c5bab839bdb155c85a7c644c71"
 
 SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
index 77630e3c70e514844125e442ab84ec9c850afa8f..f0c6a0366d9cac3df36d9825ebf7614acd3b46f4 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
 
 DEPENDS += "gperf-native"
 
-SRCREV ?= "1ac3eaa6bcc473a56340c24511786ff48a91293e"
+SRCREV ?= "d461c9682d4954076f9ee9e07be903c2eef8e73b"
 
 #SRCBRANCH ?= "release/${PV}/master"
 SRCBRANCH ?= "master"