]> code.ossystems Code Review - openembedded-core.git/commitdiff
Revert "rpm: add a patch to help with Docker performance issues"
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Thu, 31 May 2018 07:42:27 +0000 (09:42 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Jun 2018 14:14:43 +0000 (15:14 +0100)
This reverts commit 6f1822e5f1eaafd8bc46e999de730c1fcca77f3a.

This patch only solved a part of the problem.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch [deleted file]
meta/recipes-devtools/rpm/rpm_4.14.1.bb

diff --git a/meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch b/meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch
deleted file mode 100644 (file)
index 4651409..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From 982e47df7b82c5ffe3c414cf5641f08dba0f0e64 Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Fri, 26 Jan 2018 16:32:04 +0200
-Subject: [PATCH] Revert "Set FD_CLOEXEC on opened files before exec from lua
- script is called"
-
-This reverts commit 7a7c31f551ff167f8718aea6d5048f6288d60205.
-The reason is that when _SC_OPEN_MAX is much higher than the usual 1024
-(for example inside docker), the performance drops sharply.
-
-Upstream has been notified:
-https://bugzilla.redhat.com/show_bug.cgi?id=1537564
-
-Upstream-Status: Inappropriate [upstream needs to come up with a better fix]
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- luaext/lposix.c | 12 ------------
- 1 file changed, 12 deletions(-)
-
-diff --git a/luaext/lposix.c b/luaext/lposix.c
-index 0a7c26c71..c578c5a11 100644
---- a/luaext/lposix.c
-+++ b/luaext/lposix.c
-@@ -335,22 +335,10 @@ static int Pexec(lua_State *L)                   /** exec(path,[args]) */
-       const char *path = luaL_checkstring(L, 1);
-       int i,n=lua_gettop(L);
-       char **argv;
--      int flag, fdno, open_max;
-       if (!have_forked)
-           return luaL_error(L, "exec not permitted in this context");
--      open_max = sysconf(_SC_OPEN_MAX);
--      if (open_max == -1) {
--          open_max = 1024;
--      }
--      for (fdno = 3; fdno < open_max; fdno++) {
--          flag = fcntl(fdno, F_GETFD);
--          if (flag == -1 || (flag & FD_CLOEXEC))
--              continue;
--          fcntl(fdno, F_SETFD, FD_CLOEXEC);
--      }
--
-       argv = malloc((n+1)*sizeof(char*));
-       if (argv==NULL) return luaL_error(L,"not enough memory");
-       argv[0] = (char*)path;
--- 
-2.15.1
-
index cf26c1e8db1cf6524d335455442a45fd8cd1dcf1..ef4b737e9b9ec94d89c0572b0ca8d9dc02d5aa54 100644 (file)
@@ -39,7 +39,6 @@ SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x \
            file://0003-rpmstrpool.c-make-operations-over-string-pools-threa.patch \
            file://0004-build-pack.c-remove-static-local-variables-from-buil.patch \
            file://0001-perl-disable-auto-reqs.patch \
-           file://0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch \
            file://0001-configure.ac-add-option-for-dbus.patch \
            "