]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes: add x11 to required DISTRO_FEATURES
authorMartin Jansa <martin.jansa@gmail.com>
Mon, 9 Feb 2015 12:25:15 +0000 (13:25 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Mar 2015 15:44:22 +0000 (15:44 +0000)
* it's not complete, but recipes depending on virtual/libx11 are easiest
  to spot, I've long list of PNBLACKLIST for all recipes which cannot
  be built in distro without x11 in DISTRO_FEATURES

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
20 files changed:
meta/recipes-core/packagegroups/packagegroup-self-hosted.bb
meta/recipes-graphics/eglinfo/eglinfo-x11_1.0.bb
meta/recipes-graphics/fstests/fstests_git.bb
meta/recipes-graphics/glew/glew_1.12.0.bb
meta/recipes-graphics/libmatchbox/libmatchbox_1.11.bb
meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
meta/recipes-graphics/matchbox-wm/matchbox-wm_git.bb
meta/recipes-graphics/packagegroups/packagegroup-core-x11-base.bb
meta/recipes-graphics/packagegroups/packagegroup-core-x11-xserver.bb
meta/recipes-graphics/packagegroups/packagegroup-core-x11.bb
meta/recipes-graphics/pong-clock/pong-clock_1.0.bb
meta/recipes-graphics/startup-notification/startup-notification_0.12.bb
meta/recipes-graphics/x11-common/x11-common_0.1.bb
meta/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
meta/recipes-graphics/xrestop/xrestop_0.4.bb
meta/recipes-graphics/xtscal/xtscal_0.6.3.bb
meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
meta/recipes-support/atk/at-spi2-core_2.14.1.bb
meta/recipes-support/consolekit/consolekit_0.4.6.bb

index c4710205ba767e99fc3112ab206b4fb6bff6ef9d..47589b6ad6c678808e43bababba7576a779218f7 100644 (file)
@@ -7,7 +7,9 @@ DESCRIPTION = "Packages required to run the build system"
 PR = "r13"
 LICENSE = "MIT"
 
-inherit packagegroup
+inherit packagegroup  distro_features_check
+# rdepends on libx11-dev
+REQUIRED_DISTRO_FEATURES = "x11"
 
 PACKAGES = "\
     packagegroup-self-hosted \
index 18fc8938d61c84f44ee6b6764a92192d037a62d2..3427fdf4207919789001574fa85059e5f57efa2d 100644 (file)
@@ -5,4 +5,8 @@ include eglinfo.inc
 
 DEPENDS += "virtual/libx11"
 
+inherit distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
 SUMMARY += "(X11 version)"
index 57ff9f6d54fd9903a631c63f03a7af4aec103f0f..95c33f410b1033ade54f1e8f642ff1d621bf1b94 100644 (file)
@@ -13,4 +13,6 @@ LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac
 
 S = "${WORKDIR}/git/tests"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
index 9343604e4d3baecfd9db53e6e3b21be80ceca354..eb28c4d4f39c3ff200cff2aade69006e279f41b5 100644 (file)
@@ -18,4 +18,6 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
 SRC_URI[md5sum] = "01246c7ecd135d99be031aa63f86dca1"
 SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f48e4bf"
 
-inherit autotools lib_package pkgconfig
+inherit autotools lib_package pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
index 4acac39f0d2aaf7f88955dc2820dd4543b99c666..f2eb67560096f812e0d273cc65b4a1233f9ec001 100644 (file)
@@ -16,7 +16,9 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/${BPN}/${PV}/${BP
 SRC_URI[md5sum] = "fc6cc807f55a3e7c752d8013176875d7"
 SRC_URI[sha256sum] = "254cab52e304a3512c8df4be59d690cf3921bbb68a28ede7fe26b93534217b53"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 PACKAGECONFIG ??= "jpeg png xft xsettings"
 PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
index d7a80305e86ccb74fc191191fb1c8bfde413862b..670d9fcb9cd88ebc58e30cf2082628e2f1dbfb72 100644 (file)
@@ -28,7 +28,9 @@ SRC_URI[sha256sum] = "f274a4bc969ae192994a856b7f786c6fce96bae77f96c1c2b71dd97599
 
 S = "${WORKDIR}/Xsettings-client-0.10"
 
-inherit autotools gettext
+inherit autotools gettext distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 do_configure_prepend() {
     # This package doesn't ship with its own COPYING file and
index 154b967d2c8253625277abb551f93e0707ad1033..422d255951cf48b848f87a1cbc8fa280b5f70f25 100644 (file)
@@ -18,7 +18,9 @@ SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager \
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 FILES_${PN} = "${bindir}/* \
                ${datadir}/matchbox \
index 2eff3713bcbf089234a63648e6176aff5c0412bc..17301a05274688557eafffa9015f5d8f694e99a2 100644 (file)
@@ -3,7 +3,9 @@ DESCRIPTION = "Packages required to set up a basic working X11 session"
 LICENSE = "MIT"
 PR = "r1"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+# rdepends on matchbox-wm
+REQUIRED_DISTRO_FEATURES = "x11"
 
 RDEPENDS_${PN} = "\
     packagegroup-core-x11-xserver \
index 2d68e97383c2e462a2d7b82bebf0e8a9b826159f..c53f1b758d2e3451de8dceb7a0f8ff399bb7d467 100644 (file)
@@ -8,7 +8,9 @@ PR = "r40"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+# rdepends on XSERVER
+REQUIRED_DISTRO_FEATURES = "x11"
 
 XSERVER ?= "xserver-xorg xf86-video-fbdev xf86-input-evdev"
 XSERVERCODECS ?= ""
index fde5144b468f5d2db4523a34135f96ddd4ace1a4..3537d8cbbad1a8af4bc47adc31834bae5b45e38c 100644 (file)
@@ -5,7 +5,9 @@
 LICENSE = "MIT"
 PR = "r40"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+# rdepends on x11-common
+REQUIRED_DISTRO_FEATURES = "x11"
 
 PACKAGES = "${PN} ${PN}-utils"
 
index fe886f536d4163a6578266f0c24d12c6470aa1ad..0e1a7928f239c7c2c78fcc4ec625a1233be52a82 100644 (file)
@@ -2,6 +2,10 @@ SUMMARY = "A clock combined with a game of pong"
 LICENSE = "GPLv2+"
 DEPENDS = "virtual/libx11 xdmcp xau"
 
+inherit distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
 SRC_URI = "file://pong-clock-no-flicker.c"
 
 LIC_FILES_CHKSUM = "file://pong-clock-no-flicker.c;beginline=1;endline=23;md5=dd248d50f73f746d1ee78586b0b2ebd3"
index 363bdcd70619e30975f874816eb49ae80aba6770..6c1b93cd0ae65caa20904ec4302327e9e3a6dfa3 100644 (file)
@@ -17,7 +17,9 @@ SECTION = "libs"
 
 DEPENDS = "virtual/libx11 libsm xcb-util"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 SRC_URI = "http://www.freedesktop.org/software/startup-notification/releases/${BPN}-${PV}.tar.gz \
            file://obsolete_automake_macros.patch \
index a2d8885cc7d0ceefa44d2bdf3d5826bee4244f48..156b329486a47b77dde3db5f0f35096a5351c87a 100644 (file)
@@ -4,6 +4,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
 PR = "r47"
 
+inherit distro_features_check
+# rdepends on xdypinfo xmodmap xinit
+REQUIRED_DISTRO_FEATURES = "x11"
+
 SRC_URI = "file://etc \
            file://gplv2-license.patch"
 
index 3d98172442cfc7223d69c87bf5e3023094d9b162..ec0241fb285a2b6dbd037f1ee7fe3f8678841639 100644 (file)
@@ -16,7 +16,9 @@ SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a
 
 DEPENDS = "openssl virtual/libx11 libxext jpeg zlib libxfixes libxrandr libxdamage libxtst"
 
-inherit autotools-brokensep
+inherit autotools-brokensep distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
 PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
index 562434f16a6b5987101662205769ca45554dbee5..a9de3d7ef2c206ef50963f0b2e645d26b62b0890 100644 (file)
@@ -7,7 +7,9 @@ DEPENDS = "virtual/libx11 libxi"
 PV = "0.7.5+git${SRCPV}"
 PR = "r6"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111"
 SRC_URI = "git://github.com/tias/xinput_calibrator.git \
index 20d66be55bb6a38dd954d968f886984b8620cc08..ce5df039366e4218a87dcb9d0df8fc2b864b2a68 100644 (file)
@@ -19,4 +19,6 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/xrestop/xrestop-${PV}.tar.
 SRC_URI[md5sum] = "d8a54596cbaf037e62b80c4585a3ca9b"
 SRC_URI[sha256sum] = "67c2fc94a7ecedbaae0d1837e82e93d1d98f4a6d759828860e552119af3ce257"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
index 7e01775ce46d73936cd75968634a592a779bfb78..4bfddf06b5aa1fb5923949d58db617ae69cce85a 100644 (file)
@@ -23,7 +23,9 @@ SRC_URI = "${GPE_MIRROR}/xtscal-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "9bcab80b474d5454477d1ca166a68c34"
 SRC_URI[sha256sum] = "27b9dc2203de9b1706ca39fa6ca80ecab8807909ec901c4a345b8e41178800a1"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 do_install_append() {
     install -d ${D}${sysconfdir}/X11/Xsession.d/
index 18d8b16c7653e5c74b448704ce7298581737de77..2d046c4f7b7fa90cd43b7c044e83fb83f3a0ce6a 100644 (file)
@@ -8,7 +8,9 @@ PR = "r33"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-inherit packagegroup
+inherit packagegroup distro_features_check
+# rdepends on x11vnc
+REQUIRED_DISTRO_FEATURES = "x11"
 
 PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
 
index 8d01124d01362143bc12892e76fb0088140f0be3..1a1ce6c5ee80b0e5deffcb6b254280ef13c678f1 100644 (file)
@@ -11,7 +11,9 @@ SRC_URI[sha256sum] = "eef9660b14fdf0fb1f30d1be7c72d591fa7cbb87b00ca3a444425712f4
 
 DEPENDS = "dbus glib-2.0 virtual/libx11 libxi libxtst intltool-native"
 
-inherit autotools gtk-doc pkgconfig
+inherit autotools gtk-doc pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 EXTRA_OECONF = "--disable-introspection --disable-xevie --with-dbus-daemondir=${bindir}"
 
index dfbd11c2d1a9f5c033e8884463b9b80e85c872c2..66a892a7df5c98c432ee045124a04e1462337ef1 100644 (file)
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
 DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11"
 RDEPENDS_${PN} += "base-files"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
 
 SRC_URI = "http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-${PV}.tar.xz \
            file://sepbuildfix.patch \