]> code.ossystems Code Review - openembedded-core.git/commitdiff
xz: Fix shell after autotools changes
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 27 Jan 2020 21:54:01 +0000 (21:54 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Jan 2020 11:11:05 +0000 (11:11 +0000)
After changing autotools.bbclass, CONFIG_SHELL setting no longer works
resulting in:

xz-5.2.4-r0 do_package_qa: QA Issue: /usr/bin/xzmore contained in package xz requires /bin/bash, but no providers found in RDEPENDS_xz? [file-rdeps]

The script can use /bin/sh so set this specifically.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/xz/xz_5.2.4.bb

index 83e8fe0cd195a33f477d939e4e9c80fad4dc1344..1c4450a9e9ed38df4a9c5345f2a4ec13c6e3d611 100644 (file)
@@ -27,6 +27,8 @@ SRC_URI[md5sum] = "5ace3264bdd00c65eeec2891346f65e6"
 SRC_URI[sha256sum] = "b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145"
 UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar"
 
+CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh"
+
 inherit autotools gettext
 
 PACKAGES =+ "liblzma"
@@ -39,5 +41,3 @@ ALTERNATIVE_${PN} = "xz xzcat unxz \
                      lzma lzcat unlzma"
 
 BBCLASSEXTEND = "native nativesdk"
-
-export CONFIG_SHELL="/bin/sh"