]> code.ossystems Code Review - openembedded-core.git/commitdiff
oeqa/selftest/recipetool: Fix appendfile_binary test on opensuse131
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 25 Jun 2015 15:47:28 +0000 (16:47 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 26 Jun 2015 08:25:51 +0000 (09:25 +0100)
On OpenSUSE 13.1, /bin/ls is a symlink to /usr/bin/ls. This means the
test doesn't use a binary file an fails on that system.

Ensure we resolve any symlink using readlink to avoid this failure.

======================================================================
FAIL: test_recipetool_appendfile_binary (oeqa.selftest.recipetool.RecipetoolTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/meta/lib/oeqa/selftest/recipetool.py", line 115, in test_recipetool_appendfile_binary
    self.assertIn('WARNING: ', result.output)
AssertionError: 'WARNING: ' not found in 'Parsing recipes..done.\nNOTE: Writing append file /tmp/recipetoolqai0NY8l/recipes-core/coreutils/coreutils_8.23.bbappend\nNOTE: Copying /bin/ls to /tmp/recipetoolqai0NY8l/recipes-core/coreutils/coreutils/ls'

[YOCTO #7920]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/selftest/recipetool.py

index f3ad4934572ce3dbcbab278fcfbd960a177692ab..c08b2e467403212d11e7fdb6c61a501de9960ea8 100644 (file)
@@ -111,7 +111,9 @@ class RecipetoolTests(DevtoolBase):
 
     def test_recipetool_appendfile_binary(self):
         # Try appending a binary file
-        result = runCmd('recipetool appendfile %s /bin/ls /bin/ls -r coreutils' % templayerdir)
+        # /bin/ls can be a symlink to /usr/bin/ls
+        ls = os.readlink("/bin/ls")
+        result = runCmd('recipetool appendfile %s /bin/ls %s -r coreutils' % (templayerdir, ls))
         self.assertIn('WARNING: ', result.output)
         self.assertIn('is a binary', result.output)