]> code.ossystems Code Review - openembedded-core.git/commitdiff
python, python-native upgrade from 2.6.5 to 2.6.6
authorNitin A Kamble <nitin.a.kamble@intel.com>
Mon, 8 Nov 2010 18:34:46 +0000 (10:34 -0800)
committerSaul Wold <sgw@linux.intel.com>
Mon, 15 Nov 2010 05:08:26 +0000 (21:08 -0800)
Removed these patch:
    python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
    python/00-fix-bindir-libdir-for-cross.patch

The upstream code has changed, and it does not need the above 2 patches
(fixes) anymore.

Patches rebased to the newer code:
   python/01-use-proper-tools-for-cross-build.patch
   python/04-default-is-optimized.patch
   python/06-avoid_usr_lib_termcap_path_in_linking.patch
   python/99-ignore-optimization-flag.patch

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
15 files changed:
meta/recipes-devtools/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch [deleted file]
meta/recipes-devtools/python/python-native/04-default-is-optimized.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/04-default-is-optimized.patch with 100% similarity]
meta/recipes-devtools/python/python-native/10-distutils-fix-swig-parameter.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/10-distutils-fix-swig-parameter.patch with 100% similarity]
meta/recipes-devtools/python/python-native/11-distutils-never-modify-shebang-line.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/11-distutils-never-modify-shebang-line.patch with 100% similarity]
meta/recipes-devtools/python/python-native/12-distutils-prefix-is-inside-staging-area.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/12-distutils-prefix-is-inside-staging-area.patch with 82% similarity]
meta/recipes-devtools/python/python-native/debug.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/debug.patch with 100% similarity]
meta/recipes-devtools/python/python-native/nohostlibs.patch [moved from meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch with 81% similarity]
meta/recipes-devtools/python/python-native/sitecustomize.py [moved from meta/recipes-devtools/python/python-native-2.6.5/sitecustomize.py with 100% similarity]
meta/recipes-devtools/python/python-native_2.6.6.bb [moved from meta/recipes-devtools/python/python-native_2.6.5.bb with 91% similarity]
meta/recipes-devtools/python/python/00-fix-bindir-libdir-for-cross.patch [deleted file]
meta/recipes-devtools/python/python/01-use-proper-tools-for-cross-build.patch
meta/recipes-devtools/python/python/04-default-is-optimized.patch
meta/recipes-devtools/python/python/06-avoid_usr_lib_termcap_path_in_linking.patch
meta/recipes-devtools/python/python/99-ignore-optimization-flag.patch
meta/recipes-devtools/python/python_2.6.6.bb [moved from meta/recipes-devtools/python/python_2.6.5.bb with 97% similarity]

diff --git a/meta/recipes-devtools/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch b/meta/recipes-devtools/python/python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch
deleted file mode 100644 (file)
index 2559e3a..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-# $(exec_prefix) points to the wrong directory, when installing
-# a cross-build. @bindir@ and @libdir@ works better and doesn't
-# affect the native build.
-# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
-
-Index: Python-2.6.1/Makefile.pre.in
-===================================================================
---- Python-2.6.1.orig/Makefile.pre.in
-+++ Python-2.6.1/Makefile.pre.in
-@@ -86,8 +86,8 @@ exec_prefix= @exec_prefix@
- datarootdir=    @datarootdir@
- # Expanded directories
--BINDIR=               $(exec_prefix)/bin
--LIBDIR=               $(exec_prefix)/lib
-+BINDIR=               @bindir@
-+LIBDIR=               @libdir@
- MANDIR=               @mandir@
- INCLUDEDIR=   @includedir@
- CONFINCLUDEDIR=       $(exec_prefix)/include
similarity index 82%
rename from meta/recipes-devtools/python/python-native-2.6.5/12-distutils-prefix-is-inside-staging-area.patch
rename to meta/recipes-devtools/python/python-native/12-distutils-prefix-is-inside-staging-area.patch
index aa4393679f5808ee435d7b8e6f9e963b6c704ec0..bf4366f12b847c600b17e79a7a7b32e2eb105c43 100644 (file)
@@ -1,10 +1,10 @@
 # The proper prefix is inside our staging area.
 # Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
 
-Index: Python-2.6.1/Lib/distutils/sysconfig.py
+Index: Python-2.6.6/Lib/distutils/sysconfig.py
 ===================================================================
---- Python-2.6.1.orig/Lib/distutils/sysconfig.py
-+++ Python-2.6.1/Lib/distutils/sysconfig.py
+--- Python-2.6.6.orig/Lib/distutils/sysconfig.py
++++ Python-2.6.6/Lib/distutils/sysconfig.py
 @@ -19,8 +19,8 @@ import sys
  from distutils.errors import DistutilsPlatformError
  
@@ -25,10 +25,10 @@ Index: Python-2.6.1/Lib/distutils/sysconfig.py
 +            prefix = plat_specific and os.environ['STAGING_INCDIR'].rstrip('include')
 +        else:
 +            prefix = plat_specific and EXEC_PREFIX or PREFIX
      if os.name == "posix":
          if python_build:
-             base = os.path.dirname(os.path.abspath(sys.executable))
-@@ -112,7 +115,10 @@ def get_python_lib(plat_specific=0, stan
+@@ -116,7 +119,10 @@ def get_python_lib(plat_specific=0, stan
      sys.exec_prefix -- i.e., ignore 'plat_specific'.
      """
      if prefix is None:
@@ -40,7 +40,7 @@ Index: Python-2.6.1/Lib/distutils/sysconfig.py
  
      if os.name == "posix":
          libpython = os.path.join(prefix,
-@@ -218,7 +218,7 @@ def get_config_h_filename():
+@@ -216,7 +222,7 @@ def get_config_h_filename():
      else:
          # The name of the config.h file changed in 2.2
          config_h = 'pyconfig.h'
@@ -49,9 +49,9 @@ Index: Python-2.6.1/Lib/distutils/sysconfig.py
  
  
  def get_makefile_filename():
-@@ -226,7 +226,7 @@ def get_makefile_filename():
-     if python_build:
-         return os.path.join(os.path.dirname(sys.executable), "Makefile")
+@@ -225,7 +231,7 @@ def get_makefile_filename():
+         return os.path.join(os.path.dirname(os.path.realpath(sys.executable)),
+                             "Makefile")
      lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
 -    return os.path.join(lib_dir, "config", "Makefile")
 +    return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
similarity index 81%
rename from meta/recipes-devtools/python/python-native-2.6.5/nohostlibs.patch
rename to meta/recipes-devtools/python/python-native/nohostlibs.patch
index 7020f3c2a9f95208f7bfff8094588e4110c52762..da2bd8f1d230e1b9b626e8a431153b1939fbbee8 100644 (file)
@@ -1,8 +1,8 @@
-Index: Python-2.6.1/setup.py
+Index: Python-2.6.6/setup.py
 ===================================================================
---- Python-2.6.1.orig/setup.py 2009-11-13 16:20:47.000000000 +0000
-+++ Python-2.6.1/setup.py      2009-11-13 16:28:00.000000000 +0000
-@@ -310,8 +310,8 @@
+--- Python-2.6.6.orig/setup.py
++++ Python-2.6.6/setup.py
+@@ -356,8 +356,8 @@ class PyBuildExt(build_ext):
  
      def detect_modules(self):
          # Ensure that /usr/local is always used
@@ -13,7 +13,7 @@ Index: Python-2.6.1/setup.py
  
          # Add paths specified in the environment variables LDFLAGS and
          # CPPFLAGS for header and library files.
-@@ -347,10 +347,10 @@
+@@ -393,10 +393,10 @@ class PyBuildExt(build_ext):
                      for directory in reversed(options.dirs):
                          add_dir_to_list(dir_list, directory)
  
@@ -27,7 +27,7 @@ Index: Python-2.6.1/setup.py
                              sysconfig.get_config_var("INCLUDEDIR"))
  
          try:
-@@ -361,11 +361,8 @@
+@@ -407,11 +407,8 @@ class PyBuildExt(build_ext):
          # lib_dirs and inc_dirs are used to search for files;
          # if a file is found in one of those directories, it can
          # be assumed that no additional -I,-L directives are needed.
@@ -41,10 +41,10 @@ Index: Python-2.6.1/setup.py
          exts = []
          missing = []
  
-@@ -583,8 +580,7 @@
-                 readline_libs.append('ncurses')
-             elif self.compiler.find_library_file(lib_dirs, 'curses'):
-                 readline_libs.append('curses')
+@@ -661,8 +658,7 @@ class PyBuildExt(build_ext):
+                 pass # Issue 7384: Already linked against curses or tinfo.
+             elif curses_library:
+                 readline_libs.append(curses_library)
 -            elif self.compiler.find_library_file(lib_dirs +
 -                                               ['/usr/lib/termcap'],
 +            elif self.compiler.find_library_file(lib_dirs,
similarity index 91%
rename from meta/recipes-devtools/python/python-native_2.6.5.bb
rename to meta/recipes-devtools/python/python-native_2.6.6.bb
index cb95e4b96455d23f4ad5e21e31888c77ab6b463b..148dc587e9696ea7e3888723590936bc133562c7 100644 (file)
@@ -1,9 +1,9 @@
 require python.inc
 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.0"
+
 
 SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
-           file://00-fix-bindir-libdir-for-cross.patch \
            file://04-default-is-optimized.patch \
            file://05-enable-ctypes-cross-build.patch \
            file://10-distutils-fix-swig-parameter.patch \
diff --git a/meta/recipes-devtools/python/python/00-fix-bindir-libdir-for-cross.patch b/meta/recipes-devtools/python/python/00-fix-bindir-libdir-for-cross.patch
deleted file mode 100644 (file)
index 2559e3a..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-# $(exec_prefix) points to the wrong directory, when installing
-# a cross-build. @bindir@ and @libdir@ works better and doesn't
-# affect the native build.
-# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
-
-Index: Python-2.6.1/Makefile.pre.in
-===================================================================
---- Python-2.6.1.orig/Makefile.pre.in
-+++ Python-2.6.1/Makefile.pre.in
-@@ -86,8 +86,8 @@ exec_prefix= @exec_prefix@
- datarootdir=    @datarootdir@
- # Expanded directories
--BINDIR=               $(exec_prefix)/bin
--LIBDIR=               $(exec_prefix)/lib
-+BINDIR=               @bindir@
-+LIBDIR=               @libdir@
- MANDIR=               @mandir@
- INCLUDEDIR=   @includedir@
- CONFINCLUDEDIR=       $(exec_prefix)/include
index e89faa4fb07749c136c25b468c9703513de9a1cf..e091431ab2b52affc8061e4a10128ea3d529ebf4 100644 (file)
@@ -2,10 +2,10 @@
 # built cross-tools (this will not work), so we introduce HOSTPYTHON and HOSTPGEN.
 # Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
 
-Index: Python-2.6.1/Makefile.pre.in
+Index: Python-2.6.6/Makefile.pre.in
 ===================================================================
---- Python-2.6.1.orig/Makefile.pre.in
-+++ Python-2.6.1/Makefile.pre.in
+--- Python-2.6.6.orig/Makefile.pre.in
++++ Python-2.6.6/Makefile.pre.in
 @@ -175,6 +175,7 @@ UNICODE_OBJS=   @UNICODE_OBJS@
  
  PYTHON=               python$(EXE)
@@ -27,14 +27,14 @@ Index: Python-2.6.1/Makefile.pre.in
  # Build the shared modules
  sharedmods: $(BUILDPYTHON)
        @case $$MAKEFLAGS in \
--      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
--      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
-+      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
-+      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
+-      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' LDFLAGS='$(LDFLAGS)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
+-      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' LDFLAGS='$(LDFLAGS)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
++      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' LDFLAGS='$(LDFLAGS)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
++      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' LDFLAGS='$(LDFLAGS)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
        esac
  
  # Build static library
-@@ -513,7 +514,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
+@@ -517,7 +518,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
  
  $(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
                -@$(INSTALL) -d Include
@@ -43,7 +43,7 @@ Index: Python-2.6.1/Makefile.pre.in
  
  $(PGEN):      $(PGENOBJS)
                $(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-@@ -879,23 +880,23 @@ libinstall:      build_all $(srcdir)/Lib/$(PL
+@@ -887,23 +888,23 @@ libinstall:      build_all $(srcdir)/Lib/$(PL
        done
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
        PYTHONPATH=$(DESTDIR)$(LIBDEST)  $(RUNSHARED) \
@@ -72,7 +72,7 @@ Index: Python-2.6.1/Makefile.pre.in
  
  # Create the PLATDIR source directory, if one wasn't distributed..
  $(srcdir)/Lib/$(PLATDIR):
-@@ -993,7 +994,7 @@ libainstall:       all
+@@ -1001,7 +1002,7 @@ libainstall:     all
  # Install the dynamically loadable modules
  # This goes into $(exec_prefix)
  sharedinstall:
@@ -81,11 +81,11 @@ Index: Python-2.6.1/Makefile.pre.in
                --prefix=$(prefix) \
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
-Index: Python-2.6.1/setup.py
+Index: Python-2.6.6/setup.py
 ===================================================================
---- Python-2.6.1.orig/setup.py
-+++ Python-2.6.1/setup.py
-@@ -276,6 +276,7 @@ class PyBuildExt(build_ext):
+--- Python-2.6.6.orig/setup.py
++++ Python-2.6.6/setup.py
+@@ -322,6 +322,7 @@ class PyBuildExt(build_ext):
              self.failed.append(ext.name)
              self.announce('*** WARNING: renaming "%s" since importing it'
                            ' failed: %s' % (ext.name, why), level=3)
@@ -93,7 +93,7 @@ Index: Python-2.6.1/setup.py
              assert not self.inplace
              basename, tail = os.path.splitext(ext_filename)
              newname = basename + "_failed" + tail
-@@ -310,8 +311,8 @@ class PyBuildExt(build_ext):
+@@ -356,8 +357,8 @@ class PyBuildExt(build_ext):
  
      def detect_modules(self):
          # Ensure that /usr/local is always used
@@ -104,7 +104,7 @@ Index: Python-2.6.1/setup.py
  
          # Add paths specified in the environment variables LDFLAGS and
          # CPPFLAGS for header and library files.
-@@ -410,6 +411,9 @@ class PyBuildExt(build_ext):
+@@ -456,6 +457,9 @@ class PyBuildExt(build_ext):
  
          # XXX Omitted modules: gl, pure, dl, SGI-specific modules
  
index 805f4f696c7dff139f38ef7aeab1852eb5a38331..c4617ab86336099bc39c4dda766e8601b62e5001 100644 (file)
@@ -3,10 +3,10 @@
 # of opt-out.
 # Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
 
-Index: Python-2.6.1/Python/compile.c
+Index: Python-2.6.6/Python/compile.c
 ===================================================================
---- Python-2.6.1.orig/Python/compile.c
-+++ Python-2.6.1/Python/compile.c
+--- Python-2.6.6.orig/Python/compile.c
++++ Python-2.6.6/Python/compile.c
 @@ -32,7 +32,7 @@
  #include "symtable.h"
  #include "opcode.h"
@@ -16,10 +16,10 @@ Index: Python-2.6.1/Python/compile.c
  
  #define DEFAULT_BLOCK_SIZE 16
  #define DEFAULT_BLOCKS 8
-Index: Python-2.6.1/Modules/main.c
+Index: Python-2.6.6/Modules/main.c
 ===================================================================
---- Python-2.6.1.orig/Modules/main.c
-+++ Python-2.6.1/Modules/main.c
+--- Python-2.6.6.orig/Modules/main.c
++++ Python-2.6.6/Modules/main.c
 @@ -40,7 +40,7 @@ static char **orig_argv;
  static int  orig_argc;
  
@@ -39,14 +39,14 @@ Index: Python-2.6.1/Modules/main.c
  -Q arg : division options: -Qold (default), -Qwarn, -Qwarnall, -Qnew\n\
  -s     : don't add user site directory to sys.path; also PYTHONNOUSERSITE\n\
  -S     : don't imply 'import site' on initialization\n\
-@@ -353,8 +352,8 @@ Py_Main(int argc, char **argv)
+@@ -328,8 +327,8 @@ Py_Main(int argc, char **argv)
  
-               /* case 'J': reserved for Jython */
+         /* case 'J': reserved for Jython */
  
--              case 'O':
--                      Py_OptimizeFlag++;
-+              case 'N':
-+                      Py_OptimizeFlag=0;
-                       break;
+-        case 'O':
+-            Py_OptimizeFlag++;
++        case 'N':
++            Py_OptimizeFlag=0;
+             break;
  
-               case 'B':
+         case 'B':
index 30aa50dd44d8d5ef5257d2519ab0ea1063bc1fdb..68c9d5cfd56742e5a7dbabd6eec23beb86821926 100644 (file)
@@ -7,14 +7,14 @@ This Patch fixes this issue in the python build environment.
 11 Oct 2010
 Nitin A Kamble <nitin.a.kamble@intel.com>
 
-Index: Python-2.6.5/setup.py
+Index: Python-2.6.6/setup.py
 ===================================================================
---- Python-2.6.5.orig/setup.py
-+++ Python-2.6.5/setup.py
-@@ -591,12 +591,10 @@ class PyBuildExt(build_ext):
-                 readline_libs.append('ncurses')
-             elif self.compiler.find_library_file(lib_dirs, 'curses'):
-                 readline_libs.append('curses')
+--- Python-2.6.6.orig/setup.py
++++ Python-2.6.6/setup.py
+@@ -665,12 +665,10 @@ class PyBuildExt(build_ext):
+                 pass # Issue 7384: Already linked against curses or tinfo.
+             elif curses_library:
+                 readline_libs.append(curses_library)
 -            elif self.compiler.find_library_file(lib_dirs +
 -                                               ['/usr/lib/termcap'],
 +            elif self.compiler.find_library_file(lib_dirs,
index 02dc44c84771356a9f207ebed874f605c7d32f7d..0bd1a2d4d0d41c49eaf4e50c01704fea18cfade5 100644 (file)
@@ -3,17 +3,17 @@
 #
 # Signed-off-by: Denys Dmytriyenko <denis@denix.org>
 
-Index: Python-2.6.1/Modules/main.c
+Index: Python-2.6.6/Modules/main.c
 ===================================================================
---- Python-2.6.1-orig/Modules/main.c
-+++ Python-2.6.1/Modules/main.c
-@@ -352,6 +352,9 @@ Py_Main(int argc, char **argv)
+--- Python-2.6.6.orig/Modules/main.c
++++ Python-2.6.6/Modules/main.c
+@@ -327,6 +327,9 @@ Py_Main(int argc, char **argv)
  
-               /* case 'J': reserved for Jython */
+         /* case 'J': reserved for Jython */
  
-+              case 'O': /* ignore it */
-+                      break;
++              case 'O': /* ignore it */
++                      break;
 +
-               case 'N':
-                       Py_OptimizeFlag=0;
-                       break;
+         case 'N':
+             Py_OptimizeFlag=0;
+             break;
similarity index 97%
rename from meta/recipes-devtools/python/python_2.6.5.bb
rename to meta/recipes-devtools/python/python_2.6.6.bb
index ec5442dc7c987fa186be44ae8cc3141a335f1037..fa0e2941587ece2569d269430b90f3bdbf9b0b29 100644 (file)
@@ -1,12 +1,10 @@
 require python.inc
 DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
 DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.0"
 
 SRC_URI = "\
   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
-  file://00-fix-bindir-libdir-for-cross.patch \
   file://01-use-proper-tools-for-cross-build.patch \
   file://02-remove-test-for-cross.patch \
   file://03-fix-tkinter-detection.patch \