]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance: make the inclusion of downloaded sources optional
authorJoshua Lock <joshua.g.lock@intel.com>
Fri, 11 Mar 2016 12:13:32 +0000 (12:13 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 12 Mar 2016 22:11:19 +0000 (22:11 +0000)
Including the entirety of DL_DIR in the generated build appliance
image adds a significant amount of space and makes the build
appliance image more awkward to distribute. Add a configuration
option to make the inclusion of sources option and default to
disabling this functionality.

Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/build-appliance-image_14.0.0.bb

index 8f9ce1b6626d6b5dde43686f932b5e84d12551bb..61f69f42ec294b115bce159b8fd099309d0139ce 100644 (file)
@@ -26,6 +26,7 @@ SRC_URI = "git://git.yoctoproject.org/poky \
            file://Yocto_Build_Appliance.vmx \
            file://Yocto_Build_Appliance.vmxf \
           "
+BA_INCLUDE_SOURCES ??= "0"
 
 IMAGE_CMD_ext4_append () {
        # We don't need to reserve much space for root, 0.5% is more than enough
@@ -42,7 +43,9 @@ fakeroot do_populate_poky_src () {
 
        mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/conf
        mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/downloads
-       cp -RpL ${DL_DIR}/* ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/
+       if [ ${BA_INCLUDE_SOURCES} != 0 ]; then
+               cp -RpL ${DL_DIR}/* ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/
+       fi
 
        # Remove the git2_* tarballs -- this is ok since we still have the git2/.
        rm -rf ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/git2_*