]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-docutils: move to Python 3
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Thu, 2 Jun 2016 09:25:58 +0000 (12:25 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jun 2016 10:45:25 +0000 (11:45 +0100)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-dbus_1.2.4.bb
meta/recipes-devtools/python/python3-docutils_0.12.bb [moved from meta/recipes-devtools/python/python-docutils_0.12.bb with 92% similarity]

index c058cafcf129fd5a293735a31c7bc3378a546543..759512c396ee16eda772ab8dd73665a1cbbf4798 100644 (file)
@@ -15,8 +15,8 @@ S = "${WORKDIR}/dbus-python-${PV}"
 inherit distutils3-base autotools pkgconfig
 
 PACKAGECONFIG ?= ""
-PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
-PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
 
 do_configure_prepend() {
     export PYTHON=${PYTHON}
similarity index 92%
rename from meta/recipes-devtools/python/python-docutils_0.12.bb
rename to meta/recipes-devtools/python/python3-docutils_0.12.bb
index 8cda88d277c203508170973e05f241b906c750fc..e78fa3bbc8173fdaa7a8e069e47c52b63a3c3449 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "devel/python"
 LICENSE = "PSF & BSD-2-Clause & GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING.txt;md5=a722fbdc20347db7b69223594dd54574"
 
-DEPENDS = "python"
+DEPENDS = "python3"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/docutils/docutils-${PV}.tar.gz"
 SRC_URI[md5sum] = "4622263b62c5c771c03502afa3157768"
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "c7db717810ab6965f66c8cf0398a98c9d8df982da39b4cd7f162911eb8
 
 S = "${WORKDIR}/docutils-${PV}"
 
-inherit distutils
+inherit distutils3
 
 BBCLASSEXTEND = "native"