]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: Add --enable-prologues to configuration
authorTom Zanussi <tom.zanussi@linux.intel.com>
Tue, 31 Dec 2013 19:59:24 +0000 (13:59 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jan 2014 12:55:25 +0000 (12:55 +0000)
In some cases, the debuginfo generated by the compiler is insufficient
for systemtap to figure out function param locations; using -P allows
it to use prologue searching to find the correct locations.

Enable prologue searching in the configuration so the user doesn't
have to specify it manually.

Fixes [YOCTO #5403].

Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/systemtap/systemtap_git.bb

index e346ce2440d9014bc257b78ce08533e51ea78b08..488d417150564daf639efbebfcbd70f4d91a04e1 100644 (file)
@@ -12,7 +12,7 @@ RDEPENDS_${PN}_class-nativesdk += "python-native"
 
 EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
             --without-nss --without-avahi --without-dyninst \
-            --disable-server --disable-grapher \
+            --disable-server --disable-grapher --enable-prologues \
             ac_cv_prog_have_javac=no \
             ac_cv_prog_have_jar=no "