]> code.ossystems Code Review - openembedded-core.git/commitdiff
libtool: Set CONFIG_SHELL for nativesdk
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 Jan 2014 10:24:42 +0000 (10:24 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 Jan 2014 15:43:29 +0000 (15:43 +0000)
We're seeing similar failures that we saw from libtool-native and libtool-cross
where /bin/sh changed from bash to dash on different machines after sstate
reusage. This patch fixes nativesdk to avoid the same issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb

index 7b5c97a97aa1da1af71cf0f3ae378b8252cbc54e..fff15e916dc0341d75af59a365dd251f5aa557e2 100644 (file)
@@ -31,3 +31,5 @@ libtoolnativesdk_sysroot_preprocess () {
        install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
        install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool
 }
+
+export CONFIG_SHELL="/bin/bash"