]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-sax-perl: inherit ptest-perl
authorTim Orling <timothy.t.orling@linux.intel.com>
Mon, 5 Mar 2018 03:25:17 +0000 (19:25 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Mar 2018 14:13:59 +0000 (06:13 -0800)
* Enable ptest by inheriting new ptest-perl.bbclass
* Install testfiles/ into PTEST_PATH

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/perl/libxml-sax-perl_0.99.bb

index ad31b9c9d291ee721834cdde200628f61e8d965f..cdcbebffce61eafacced367952cd7f0aaaf1e904 100644 (file)
@@ -23,6 +23,11 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
 
 S = "${WORKDIR}/XML-SAX-${PV}"
 
-inherit cpan
+inherit cpan ptest-perl
+
+do_install_ptest() {
+       cp -r ${B}/testfiles ${D}${PTEST_PATH}
+       chown -R root:root ${D}${PTEST_PATH}/testfiles
+}
 
 BBCLASSEXTEND = "native"