]> code.ossystems Code Review - openembedded-core.git/commitdiff
go: upgrade 1.15.2 -> 1.15.3
authorAlexander Kanavin <alex.kanavin@gmail.com>
Mon, 2 Nov 2020 16:48:40 +0000 (17:48 +0100)
committerAnuj Mittal <anuj.mittal@intel.com>
Mon, 28 Dec 2020 01:53:26 +0000 (09:53 +0800)
Set PV directly to allow automated version updates between point releases.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 84034ea18a9fb1a012a1ecdc3a84296b08d3cc23)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-devtools/go/go-1.15.inc
meta/recipes-devtools/go/go-binary-native_1.15.3.bb [moved from meta/recipes-devtools/go/go-binary-native_1.15.2.bb with 83% similarity]
meta/recipes-devtools/go/go-runtime_1.15.bb
meta/recipes-devtools/go/go_1.15.bb

index 97d748b922f4fae49f943c9648a82f982a3c35a1..a35921c1f81234d8d3ea1a544da6036c5b51870c 100644 (file)
@@ -1,8 +1,7 @@
 require go-common.inc
 
 GO_BASEVERSION = "1.15"
-GO_MINOR = ".2"
-PV .= "${GO_MINOR}"
+PV = "1.15.3"
 FILESEXTRAPATHS_prepend := "${FILE_DIRNAME}/go-${GO_BASEVERSION}:"
 
 LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
@@ -17,4 +16,4 @@ SRC_URI += "\
     file://0007-cmd-go-make-GOROOT-precious-by-default.patch \
     file://0008-use-GOBUILDMODE-to-set-buildmode.patch \
 "
-SRC_URI[main.sha256sum] = "28bf9d0bcde251011caae230a4a05d917b172ea203f2a62f2c2f9533589d4b4d"
+SRC_URI[main.sha256sum] = "896a602570e54c8cdfc2c1348abd4ffd1016758d0bd086ccd9787dbfc9b64888"
similarity index 83%
rename from meta/recipes-devtools/go/go-binary-native_1.15.2.bb
rename to meta/recipes-devtools/go/go-binary-native_1.15.3.bb
index ccd2d5ebad446c0bb88a382227518e32ff44b86d..aeab91a80fa9e3cd406382dcef31da0a0ccbb3e0 100644 (file)
@@ -8,8 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
 PROVIDES = "go-native"
 
 SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
-SRC_URI[go_linux_amd64.sha256sum] = "b49fda1ca29a1946d6bb2a5a6982cf07ccd2aba849289508ee0f9918f6bb4552"
-SRC_URI[go_linux_arm64.sha256sum] = "c8ec460cc82d61604b048f9439c06bd591722efce5cd48f49e19b5f6226bd36d"
+SRC_URI[go_linux_amd64.sha256sum] = "010a88df924a81ec21b293b5da8f9b11c176d27c0ee3962dc1738d2352d3c02d"
+SRC_URI[go_linux_arm64.sha256sum] = "b8b88a87ada918ef5189fa5938ef4c46a4f61952a34317612aaac705f4275f80"
 
 UPSTREAM_CHECK_URI = "https://golang.org/dl/"
 UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
index 4eeee65e0c9c6d95569c11cbf447d2d2ff84f038..d6ddb31ed4d65072b587c1ca7978bb56b3414e39 100644 (file)
@@ -1,3 +1,4 @@
 export CGO_ENABLED_riscv64 = ""
 require go-${PV}.inc
 require go-runtime.inc
+
index 4bf9dd50b2c35f9d8823cc3a109f0284ab58005d..cc4c3fe45df74a7a65ca0580da14e43e797593fd 100644 (file)
@@ -13,3 +13,4 @@ python() {
     if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
         d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
 }
+