]> code.ossystems Code Review - openembedded-core.git/commitdiff
wayland: fix condition for strndup detection
authorKhem Raj <raj.khem@gmail.com>
Tue, 12 May 2020 23:46:31 +0000 (16:46 -0700)
committerSteve Sakoman <steve@sakoman.com>
Wed, 17 Jun 2020 03:06:39 +0000 (17:06 -1000)
current check does not work with gcc10

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit ce6c50ea68c34e02b487d54fdd9288e04833cdef)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch

index e4458387500cbda58fe1a030592187e36165822f..c2ceae4a4758caaa457fa88c4ff8252627735233 100644 (file)
@@ -17,8 +17,6 @@ Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/merge
  meson.build | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/meson.build b/meson.build
-index 26b084f..c05d019 100644
 --- a/meson.build
 +++ b/meson.build
 @@ -36,11 +36,11 @@ have_funcs = [
@@ -30,10 +28,7 @@ index 26b084f..c05d019 100644
  foreach f: have_funcs
        config_h.set('HAVE_' + f.underscorify().to_upper(), cc.has_function(f))
  endforeach
-+config_h.set('HAVE_STRNDUP', cc.has_function('strndup', prefix:'#include <string.h>'))
++config_h.set('HAVE_STRNDUP', cc.has_function('strndup') and cc.has_header_symbol('string.h', 'strndup'))
  
  if get_option('libraries')
        ffi_dep = dependency('libffi')
--- 
-2.17.1
-