]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-4.3.3: Add patch for issue PR35942 to fix libstdc++ build issues with certain...
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 29 Mar 2010 21:24:50 +0000 (22:24 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 29 Mar 2010 21:24:50 +0000 (22:24 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/gcc/gcc-4.3.3.inc
meta/packages/gcc/gcc-4.3.3/pr35942.patch [new file with mode: 0644]

index e245692dc04d1c5d73f95eb43186fc4a176ae5a7..06f26274d05fa948e611c1084f6f05df0e176e3d 100644 (file)
@@ -51,6 +51,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
        file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch;patch=1 \
        file://zecke-xgcc-cpp.patch;patch=1 \
        file://gcc-flags-for-build.patch;patch=1 \
+       file://pr35942.patch;patch=1 \
 "
 
 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
diff --git a/meta/packages/gcc/gcc-4.3.3/pr35942.patch b/meta/packages/gcc/gcc-4.3.3/pr35942.patch
new file mode 100644 (file)
index 0000000..da610f5
--- /dev/null
@@ -0,0 +1,38 @@
+Fix PR 35942: remove -lstdc++ from libtool postdeps for CXX.
+
+libstdc++-v3/ChangeLog:
+2010-01-04  Ralf Wildenhues  <Ralf.Wildenhues@gmx.de>
+
+       PR libstdc++/35942
+       * configure.ac: Remove -lstdc++ from libtool's postdeps_CXX.
+       * configure: Regenerate.
+
+
+Index: gcc-4.3.3/libstdc++-v3/configure
+===================================================================
+--- gcc-4.3.3.orig/libstdc++-v3/configure      2010-03-26 17:57:51.000000000 +0000
++++ gcc-4.3.3/libstdc++-v3/configure   2010-03-26 17:57:58.000000000 +0000
+@@ -13759,6 +13759,9 @@
++# Eliminate -lstdc++ addition to postdeps for cross compiles.
++postdeps_CXX=`echo " $postdeps_CXX " | sed 's, -lstdc++ ,,g'`
++
+ # Possibly disable most of the library.
+ ## TODO: Consider skipping unncessary tests altogether in this case, rather
+ ## than just ignoring the results.  Faster /and/ more correct, win win.
+Index: gcc-4.3.3/libstdc++-v3/configure.ac
+===================================================================
+--- gcc-4.3.3.orig/libstdc++-v3/configure.ac   2010-03-26 17:57:54.000000000 +0000
++++ gcc-4.3.3/libstdc++-v3/configure.ac        2010-03-26 17:57:58.000000000 +0000
+@@ -89,6 +89,9 @@
+ AC_SUBST(enable_shared)
+ AC_SUBST(enable_static)
++# Eliminate -lstdc++ addition to postdeps for cross compiles.
++postdeps_CXX=`echo " $postdeps_CXX " | sed 's, -lstdc++ ,,g'`
++
+ # Possibly disable most of the library.
+ ## TODO: Consider skipping unncessary tests altogether in this case, rather
+ ## than just ignoring the results.  Faster /and/ more correct, win win.