]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-panel-2: Update to 2109
authorZhai Edwin <edwin.zhai@intel.com>
Tue, 6 Jul 2010 09:52:27 +0000 (17:52 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 13 Jul 2010 14:21:43 +0000 (15:21 +0100)
Also add a patch to fix the upstream compile error caused by a typo.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/packages/matchbox-panel-2/matchbox-panel-2_svn.bb
meta/packages/matchbox-panel-2/startup_fix.diff [new file with mode: 0644]

index 4e8a0bfe61eb2edffcbb4e96747843f1743f5d32..2da65d508d3038c2886ce46b202d8c7061096f23 100644 (file)
@@ -71,7 +71,7 @@ SRCREV_pn-matchbox-config-gtk ??= "2081"
 SRCREV_pn-matchbox-desktop-sato ??= "76"
 SRCREV_pn-matchbox-desktop ??= "2096"
 SRCREV_pn-matchbox-keyboard ??= "1910"
-SRCREV_pn-matchbox-panel-2 ??= "2088"
+SRCREV_pn-matchbox-panel-2 ??= "2109"
 SRCREV_pn-matchbox-panel ??= "1364"
 SRCREV_pn-matchbox-stroke ??= "1524"
 SRCREV_pn-matchbox-terminal ??= "1816"
index d75b9ef4058ba0a07ef4cee17c0396312ba336f0..45998633f49c54b53a50009d0d8210070d79d001 100644 (file)
@@ -3,6 +3,9 @@ HOMEPAGE = "http://matchbox-project.org"
 BUGTRACKER = "http://bugzilla.openedhand.com/"
 
 LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
+                    file://applets/startup/startup.c;endline=22;md5=b0a64fbef3097d79f8264e6907a98f03"
 
 PRIORITY = "optional"
 DEPENDS = "gtk+ startup-notification dbus dbus-glib"
@@ -16,7 +19,8 @@ RPROVIDES_${PN} = "matchbox-panel"
 RREPLACES_${PN} = "matchbox-panel"
 RCONFLICTS_${PN} = "matchbox-panel"
 
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+           file://startup_fix.diff;patch=1"
 
 EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
diff --git a/meta/packages/matchbox-panel-2/startup_fix.diff b/meta/packages/matchbox-panel-2/startup_fix.diff
new file mode 100644 (file)
index 0000000..9262d33
--- /dev/null
@@ -0,0 +1,17 @@
+Fixed the compile error caused by typo, upstream also need this.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: matchbox-panel-2/applets/startup/startup.c
+===================================================================
+--- matchbox-panel-2/applets/startup/startup.c (revision 2109)
++++ matchbox-panel-2/applets/startup/startup.c (working copy)
+@@ -229,7 +229,7 @@
+         applet = g_slice_new0 (StartupApplet);
+         applet->launch_list = NULL;
+-        applet->hourglass_show = FALSE;
++        applet->hourglass_shown = FALSE;
+         /* Create image */
+         applet->image = MB_PANEL_SCALING_IMAGE